Jump to content
  • 0

Technic Platform not launching Tekkit Legends




I have a problem. I installed technic platform and latest update of Java(Version 8 Update 281, the 64bit version) and every time I try to play Tekkit Legends it displays this in the console:

[main/ERROR]: Unable to launch
[B#617]  java.lang.reflect.InvocationTargetException
[B#617]      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_281]
[B#617]      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_281]
[B#617]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_281]
[B#617]      at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_281]
[B#617]      at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
[B#617]      at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
[B#617]  Caused by: java.lang.UnsatisfiedLinkError: C:\Users\Andre\AppData\Roaming\.technic\modpacks\tekkit-legends\bin\natives\lwjgl.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
[B#617]      at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[?:1.8.0_281]
[B#617]      at java.lang.ClassLoader.loadLibrary0(Unknown Source) ~[?:1.8.0_281]
[B#617]      at java.lang.ClassLoader.loadLibrary(Unknown Source) ~[?:1.8.0_281]
[B#617]      at java.lang.Runtime.loadLibrary0(Unknown Source) ~[?:1.8.0_281]
[B#617]      at java.lang.System.loadLibrary(Unknown Source) ~[?:1.8.0_281]
[B#617]      at org.lwjgl.Sys$1.run(Sys.java:73) ~[lwjgl-2.9.1.jar:?]
[B#617]      at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_281]
[B#617]      at org.lwjgl.Sys.doLoadLibrary(Sys.java:66) ~[lwjgl-2.9.1.jar:?]
[B#617]      at org.lwjgl.Sys.loadLibrary(Sys.java:95) ~[lwjgl-2.9.1.jar:?]
[B#617]      at org.lwjgl.Sys.<clinit>(Sys.java:112) ~[lwjgl-2.9.1.jar:?]
[B#617]      at net.minecraft.client.Minecraft.func_71386_F(Minecraft.java:2671) ~[bao.class:?]
[B#617]      at net.minecraft.client.main.Main.main(SourceFile:72) ~[Main.class:?]
[B#617]      ... 6 more

I have tried deleting .technic and installing the platform again but it does not work. The only thing that worked was installing the 32bit version of Java, but only works for Singleplayer and crashes when I try to connect to a server as it only has 1Gb of ram allocated. Does anyone know how to make it launch on 64bit?

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...