Jump to content
  • 0

Intel Iris Xe Graphics Can't Run Tekkit Classic



My girlfriend bought a new laptop with the express purpose of being able to play on Tekkit Classic with me. I installed it all and set it up but whenever I load into the game most of the graphics bug out. Whenever I mine a block of anything, my inventory turns plain white, or plain black, and the graphics of my surroundings disappear completely or turn a plain black, grey, or brown. It is unplayable as you cannot make sense of anything around you. 

I have seen that backdating the driver will get it to work but my laptop won't let me install a previous driver. I have tried turning off the firewall, turning integrity off, allocating more RAM to Tekkit and the Technic Launcher, using a texture pack, and uninstalling and reinstalling multiple times but nothing works.

I have tried loading up normal Tekkit and that seems to work pretty much fine - very minor graphics bugs but definitely playable. Nothing I do will get this to work and we are passed the point of being able to return the laptop. Are they are techniques or tips that I haven't tried?

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...