Jump to content

Insta-Crash Help for a Mac user??


Recommended Posts

So I'm trying to launch anything in the Technic Launcher. Double click my 'Technic-launcher.jar' and it opened up. The first 'icon' comes up then blinks off then back up. Then the launcher it's self opens up. I log in with my account, all is well. I try to open anything--including vanilla-- and it opens up, right? Sits there on the grey screen with the 'vanilla' or 'tekkit' or whatever I'm trying to open on the top bar. Here's the troublesome part: It'll sit there on the grey screen for a little, perhaps blink to a black/dark blue screen, blink back to grey, and shut down entirely. I've tried deleting the launcher and reinstalling. I've tried deleting ALL related information for it in ~/library/Application Support/techniclauncher. Hell, I even deleted the whole folder to start over. What can I do to stop this or am I screwed until a new update pops up and fixes this bug?

Link to comment
Share on other sites

If you're having the same problem as i did, it's because the Technic Launcher won't run on Java 7 (on OS X anyway). Try typing this in Terminal.app:

export JAVA_HOME=/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/

java -jar /Applications/TechnicLauncher.jar

(assuming techniclauncher jar is located in /Applications)

Otherwise, you can try uninstalling/removing Oracle Java 7 from your Mac and restoring Sun Java 6 JDK

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...