Jump to content

Config corruption-> attempted fix -> cannot log into launcher any more: "Update Failed!"


eekee
 Share

Recommended Posts

Hullo. I play Tekkit Classic on a server with some friends. The server's been around a while, and I've been happily logging into it and using it. Some lag, but it worked; nothing strange. There's no reason for me to mess about with the launcher or the installation at all, so I don't. Yesterday, the game crashed during one of the re-logs which are occasionally forced by server lag. That was the first time it had done that. On starting it back up, it complained about duplicate block ids, which I can only assume must be the result of some sort of corruption of the files on disk, as it was working 10 minutes before.

A couple of tries got the same results, and then I decide to clean out the installation. Rather than remove the files, I looked around the launcher, found the "clear cache" button, pressed it, and tried to log in. It showed a progress bar downloading minecraft.jar which runs from 0 to 100% 4 times and then a little dialog pops up with the message, "Update Failed!"

That was several hours ago. Trying again just now got the same results, so I decided to clean out all of the launcher's files, it's a linux box so "rm -rf .techniclauncher" was what I did. Starting the launcher after that, I had to reenter my login info and select Tekkit Classic of course, but attempting to log in got the same error; "Update Failed!" Is it finding minecraft.jar is corrupted or what?

((Also wtf; first forum I've ever used that requires html tags to make paragraphs! It's a forum, not god's own display of web technology.))

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...