Jump to content

Hexxit Fail on start - Multicraft panel


Smyte
 Share

Recommended Posts

I have been successfully running a hosted TekkitLite server for a long time now, using the same host and same Multicraft panel.

I recently decided to make a clean, unmodified Hexxit server (new account, same host, also Mulitcraft). Uploaded files. Started server and get:

Exception in thread "main" java.lang.NoClassDefFoundError: mc

I have zero java savvy. My google research says that this error shows when a file is present at "compile time" but not present at "runtime". This seems unlikely to be the case when hundreds of other people unzip Hexxit and it runs.

Therefore, my conclusion (perhaps entirely wrong) is that there is something about the interaction between the file structure (on my hosted server) and the Hexxit coding that has java looking for files in the wrong directory? Maybe?

So my problem is this... I can't change the server file directory and I don't have the knowledge (or inclination, really) to try to uncompile Hexxit and change the pathing issue.

Questions:

1. Have I diagnosed this correctly? Is there another explanation?

2. Can this be fixed? How?

Update: no update -

I'm trying to be patient.

I have tried multiple re-installations. I have tried both uploading the files freshly unzipped but never run. I have also unzipped the files, run them on my home system, logged into the world, then uploaded those (clearly working) files.

No one has even a guess? Is there some reason a full error report would be helpful?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...