Jump to content

[SOLVED] Voltz Server crashes on startup "Exception in server tick loop"


Recommended Posts

So when I get a fresh copy of the Voltz server for Voltz 1.0.11 and try running the .bat, everything seems to pre-initialize but then I get this mysterious crash about BouncyCastleProvider:


---- Minecraft Crash Report ----

// Why did you do that?

Time: 7/20/13 9:15 PM

Description: Exception in server tick loop

java.lang.NoClassDefFoundError: org/bouncycastle/jce/provider/BouncyCastleProvider

at ho.c(DedicatedServer.java:112)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:458)

at fy.run(SourceFile:849)

Caused by: java.lang.ClassNotFoundException: org.bouncycastle.jce.provider.BouncyCastleProvider

at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:185)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

... 3 more

Caused by: java.lang.NullPointerException

at org.objectweb.asm.ClassReader.<init>(Unknown Source)

at codechicken.core.asm.ClassHeirachyManager.transform(ClassHeirachyManager.java:80)

at cpw.mods.fml.relauncher.RelaunchClassLoader.runTransformers(RelaunchClassLoader.java:228)

at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:173)

... 5 more

A detailed walkthrough of the error, its code path and all known details is as follows:


-- System Details --


Minecraft Version: 1.4.7

Operating System: Windows 7 (amd64) version 6.1

Java Version: 1.7.0_17, Oracle Corporation

Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

Memory: 214864552 bytes (204 MB) / 231735296 bytes (221 MB) up to 2863333376 bytes (2730 MB)

JVM Flags: 1 total; -Xmx3G

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

Suspicious classes: FML and Forge are installed

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

FML: MCP v7.26a FML v4.7.35.556 Minecraft Forge 18 mods loaded, 18 mods active

mcp [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized

FML [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized

Forge [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized

CodeChickenCore [CodeChicken Core] (coremods) Unloaded->Constructed->Pre-initialized

NotEnoughItems [Not Enough Items] (coremods) Unloaded->Constructed->Pre-initialized

BasicComponents [basic Components] (BasicComponents_v1.2.4.335.jar) Unloaded->Constructed->Pre-initialized

AssemblyLine [Assembly Line] (AssemblyLine_v0.2.4.62.jar) Unloaded->Constructed->Pre-initialized

AtomicScience [Atomic Science] (AtomicScience_v0.3.4.134.jar) Unloaded->Constructed->Pre-initialized

BlastCraft [blastCraft] (BlastCraft_v0.6.1.25.jar) Unloaded->Constructed->Pre-initialized

ElectricExpansion [Electric Expansion] (ElectricExpansion_v1.3.9.jar) Unloaded->Constructed->Pre-initialized

Liquid Mechanics [Liquid Mechanics] (Fluid-Mechanics_v0.2.6.14.jar) Unloaded->Constructed->Pre-initialized

ICBM [iCBM] (ICBM_v1.0.3.129.jar) Unloaded->Constructed->Pre-initialized

Mekanism [Mekanism] (Mekanism-v5.2.0.jar) Unloaded->Constructed->Pre-initialized

MekanismGenerators [MekanismGenerators] (MekanismGenerators-v5.2.0.jar) Unloaded->Constructed->Pre-initialized

MekanismTools [MekanismTools] (MekanismTools-v5.2.0.jar) Unloaded->Constructed->Pre-initialized

ModularForceFieldSystem [Modular ForceField System V2] (ModularForceFieldSystemV2. Unloaded->Constructed->Pre-initialized

mmmPowersuits [MachineMuse's Modular Powersuits] (ModularPowersuits-0.2.0-23.jar) Unloaded->Constructed->Pre-initialized

Railcraft [Railcraft] (Railcraft_1.4.6- Unloaded->Constructed->Pre-initialized

Profiler Position: N/A (disabled)

Is Modded: Definitely; Server brand changed to 'forge,fml'

Type: Dedicated Server (map_server.txt)

I can't figure out what I can do to fix it because it doesn't seem to be caused by any of the mods, any ideas that might help?

Link to comment
Share on other sites

I fixed it, turns out Forge was having trouble downloading all the libraries it needed to run (probably had to do with my antivirus or something), so I just got a copy of the lib folder that had all the files and replaced the one it had half-way created.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...