Jump to content

Perhaps a server is already running on that port? Server problem


Recommended Posts

Hey guys, so I have this problem while running a hamachi Tekkit Classic server. When I first started the server, I put in my hamachi ip on the server properties file with my friend in a group with me as well with the ip. The first couple days it worked. Then one day, I wanted my energy condenser to make diamonds overnight, so I left the server on overnight with world anchors. When I woke up, I couldn't join the server. I saw the "Perhaps a server is already running on that port" text in the server, so I realized that I probably left a server on or something and didn't correctly stop it, so I went in task manager and ended everything that had Java in it's name and restarted the server. I had the same problem. I went online and searched it up. Some people said to leave the "server-ip=" in the server.properties file blank, but then how could people join? Then I went on youtube. They said to go into command prompt and type "ipconfig" and find the ipv4 address and use it as your ip. That's what I did, and it worked. For me. My other friend could not connect. It was a Hamachi server, but using the hamachi ip gave me this:

**** FAILED TO BIND TO PORT ****

The exception was: java.net.BindException: Cannot assign requested address: JVM_Bind

Perhaps a server is already running on that port?

 

So yeah. Any help would be greatly appreciated. Thank you very much for reading.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...