Archived

This topic is now archived and is closed to further replies.

  • 0
AndyGaydon

[MAC] Technic doesn't work at all.

Question

Launcher Version: 1.1.1.

Operating System: Mac OS X 10.8.2 Mountain Kitten

Java Version: 7

Antivirus Program: None

Description of Problem:

Dear Technic Wizard Children,

I can't, for the life of me, manage to get Technic working on my Mac (OS X 10.8.2). The overall aim is to play Tekkit with a friend - I'll leave the setting-up-the-server-bit for later, but here's what happened:

1) I downloaded and extracted the launcher. It opened up, but then immediately told me there was a client update, and did I was I OK with that. I clicked OK, then within a millisecond, it said UPDATE SUCCESSFUL! It seemed OK, but when actually launching Technic, it began with a whole host of 'ID Assignment' queries, that I chose to either automatically assign, or ignore. I think I may have installed Tekkit first, then Technic. Both of those packs seemed to download/extract/install etc fairly successfully. But subsequent attempts have not, even after uninstalling/deleting everything.

2) When Technic opened, there was no Technic logo. I gather there is supposed to be one, but there wasn't one. I could play the game fine, so it works - I saw volcanoes, and I got startled by some snakes. There was a mini-map, and the birds were singing. I, however, was not.

3) I couldn't get the Texture Pack to open. Not only could I not manually find the folder anywhere (yes yes I looked in Users/Andy/Library etc etc) and pressing the 'Open Texture Pack Folder' button only seemed to flash up whatever Finder window I had open at the time, ie it didn't open the texture pack folder, as it had promised.

4) I then thought I'd open up Minecraft, just to, you know, reassure myself that the world still existed. But it didn't! I got the '(4) Failed to Launch.... ...mincraft.jar' error.

5) I swore at the computer, which was embarrassing because I was completely by myself at the time. And the computer itself is an inanimate object, devoid of any emotion or awareness of how much of a 'twat' I felt it was.

6) Regaining composure, I reinstalled Java, this time using developer version 7. I might have been on 6 before, I have no idea. Minecraft then worked again.

7) Now optimistic, I re-downloaded and extracted the launcher again, just in case. I got the same nanosecond of WOULD I LIKE TO UPDATE NOW? message, but then 'installing' the Technic didn't happen - nothing extracted, but the game would open as normal (but, as before, I couldn't access the texture pack folder, nor could I see the logo etc).

8) I went to bed. By this point, it was late, and my friend James (who had been waiting patiently for me to set up a Tekkit server later) had long abandoned me on Skype.

9) Next day, I thought I'd have another stab at it. This time, however, the launcher just crashes after logging in. Or sometimes doesn't launch at all!

Do any of you technical geniuses know what, the fup, is going on? Is this a Java issue? Or did I fupup the original installation?

Where does all the Technic stuff extract to on a Mac? It's not in Application Support in my User folder, nor does it appear to be anywhere else. There's not a whiff of '.techniclauncher' anywhere. How would I do a complete reinstall of it?

Mac specs:

OS X 10.8.2 Mountain Goat

2.8Ghz Intel Core i7

12GB RAM

ATI Radeon HD 4850 512 MB

Java:

Version 7, Developer.

Error Messages:

All over the shop.

Error Log:

One once appeared, but I didn't save it. Now I can't even launch the game to get one.

Share this post


Link to post
Share on other sites

4 answers to this question

I think you're problem is you're running Mountain Goat when you should be running Mountain Llama.

You lose count of the animals after a while. Mountain Llama doesn't work, it just SPITS the installation disk out. Ammaright? wheeey. Seriously though, please address my technical issue.

Share this post


Link to post
Share on other sites

-1. Always choose to assign ID to all when that screen comes up

-2. That's not much of a problem. I'm sure you can't sing anyway.

-3. IF the TP is there, then it should be in "Library/ApplicationSupport/TechnicLauncher/TechnicSSP/TexturePacks. If not, well ya.

-4. You're Technic/Tekkit shouldn't have ANYTHING to do with your normal minecraft but the username.

-5. You're computer might be mad at you because of that, so it efs everything up.

-6. Congratulations.

-7. Why are you extracting the launcher? You just run it...

-8. My name's James too! And I also sleep!

-9. Okay, delete the Techniclauncher folder and re-install. Once you re-download, run the launcher with java. Put in your MC account info. Choose recommended build of Tekkit. That should work.

Share this post


Link to post
Share on other sites

Try this:

[This is a three part process]

Part One: [Fully Uninstall TechnicLauncher]

  1. Click on Finder to open a Finder window.
  2. Click on "Go" in your menubar, then "Go To Folder".
  3. Type in "~/Library/Application Support" without the quotation marks.
  4. Delete the folder "techniclauncher".
  5. Delete the Techniclauncher application.

Part Two: [Downgrade to Apple's Java 6 instead of Oracle's Java 7]

  1. Go here and wait for the page to load.
  2. You should get something like this if you have Oracle's Java 7 installed.
  3. Once you verify that you have Oracle's Java 7 installed, click on Finder to open a new Finder window.
  4. In the search bar search "JavaAppletPlugin.plugin". [Note: Make sure that you select "This Mac"]
  5. Delete/Move "JavaAppletPlugin.plugin" to your trash. [Note: You will only be able to empty trash when your web browser, minecraft, techniclauncher, any application that uses java is closed]
  6. Go to your applications, go into the "Utilities" folder, and open Terminal.
  7. Paste this into the Terminal window and press [ENTER]. [Note: You will have to type in your password. Your password will not show up while typing, but it IS being inputted]
  8. Type "logout" into the Terminal window.
  9. Close and quit Terminal.
  10. Go here and wait for the page to load.
  11. Make sure that you no longer have Oracle's Java 7 installed anymore.

Part Three: [Reinstall TechnicLauncher]

  1. Go here and download the latest Techniclauncher application for Mac OS X
  2. Open Techniclauncher after downloaded, and download all files needed for Technic/Tekkit/YogBox/HackMine/etc. to run by selecting the respective mod and typing in your credentials and clicking login.
  3. Technic/Tekkit/YogBox/HackMine/etc. should be working now.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.