Mc_Lovin

MoonQuest+ Modpack Crash

13 posts in this topic

I apologize if I put this in the wrong place of the forums, but this spot seemed the most fitting.

So basically, I installed the MoonQuest+ modpack. It runs fine. The only issue is the modpack does not include optifine lite for minecraft 1.6.4 (the minecraft version this modpack is running on.) I decided I would grab a .jar download to place into the mods folder of the modpack. There is no META-INF folder in there, just so you know. When I started the modpack, it will bring me to the "Mojang" loading screen and then just close down and bring me straight back to the laucher. I checked the folders inside the modpack and there was a crash report that is below. I have no clue why this is doing this, as I seem to have done everything correctly. I am also running on linux (lubuntu). Please help and if there is any more information I forgot/need to provide then please let me know. Thank you for your time. 

 

Crash report is below, sorry if I posted it wrong, as I am new to these forums and I'm not too sure as to whether or not there's a more proper way to post crash reports. 

 

[Edit] I forgot to mention the crash report is when I was installing the optifine HD version, instead of the lite. Both times I tried installed either of them the game crashed.

 

http://paste.ubuntu.com/25882400/

Edited by EvilOwl
User forgot to read the rules about posting logs

Share this post


Link to post
Share on other sites
1 hour ago, Mc_Lovin said:

I apologize if I put this in the wrong place of the forums, but this spot seemed the most fitting.

---- Minecraft Crash Report ----

// You're mean.

Time: 11/3/17 12:58 PM
Description: Initializing game

java.lang.NoSuchMethodError: net.minecraft.client.renderer.texture.TextureMap.setTextureEntry(Ljava/lang/String;Lnet/minecraft/client/renderer/texture/TextureAtlasSprite;)Z
    at mods.railcraft.client.util.textures.TextureAtlasSheet.unstitchIcons(TextureAtlasSheet.java:46)
    at mods.railcraft.client.util.textures.TextureAtlasSheet.unstitchIcons(TextureAtlasSheet.java:36)
    at mods.railcraft.common.blocks.detector.BlockDetector.func_94332_a(BlockDetector.java:223)
    at net.minecraft.client.renderer.texture.TextureMap.func_110573_f(TextureMap.java:150)
    at net.minecraft.client.renderer.texture.TextureMap.<init>(TextureMap.java:29)
 

    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 803037568 bytes (765 MB) / 1012400128 bytes (965 MB) up to 1012400128 bytes (965 MB)
 

This particular error is usually a disguised Out.of.Memory error. Considering you are running 64-bit java, please look if it still crashes with, say, 2 GB of RAM, instead of your current 1 GB.

Share this post


Link to post
Share on other sites

I actually got it to work, there was meta-inf inside of the files of it. Only problem now is the mod won't actually download into the game itself, even though it doesn't crash.

Share this post


Link to post
Share on other sites
1 hour ago, EvilOwl said:

Moved to the correct forum section.

Thank you. Also, would you by any chance know how to solve this problem?

Share this post


Link to post
Share on other sites

I would totally not use a pack that's for mc 1.6.4 in 2017. Find Something more recent and half of your trouble will be gone.

Note that the original Moonquest modpack is hosted on  the ATLauncher, not Technic, this was probably just somebody porting it with some custom changes.

Also idk what are you trying to do with META-INF, afaik in 1.6.4 you just had to drop a jar in the mods directory without modifying minecraft's jar.

The crash you were getting was caused by low memory settings in the launcher and/or using 32 bit java instead of 64 bit java just like Jaari said in his first post in this topic.

Share this post


Link to post
Share on other sites

@EvilOwl Yes, I tried ATlauncher. For some odd reason The .jar file for optifine is just not recognized. It is extremely annoying as I need optifine to play the game smoothly until I can afford a new computer, but that’s besides the topic and main point. I’m not sure what’s causing it to not be recognized as an installed mod. I’m going to try to figure it out some more, but if you have any pointers or ideas as to why this is happening that would be much appreciated. Thank you for your help so far. Also, I made sure to read the rules as I didn’t do that before.

Share this post


Link to post
Share on other sites

I already fixed that. I also got ATlauncher to work, and I have optifine on it. I just play minecraft with the screen a downsized because I’m playing at 1080p and I seem to get a solid 40-30 fps. I’m not sure if having the light version of optifine will make a difference in performance, though.

So, say I wanted to replace the ultra version of optifine in ATlauncher with the light version, how exactly would I do that and still have the launcher recognize the mod that I installed? And would it be worth it to replace the ultra version with the light version?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now