Kkajr

Members
  • Content Count

    1
  • Joined

  • Last visited

  1. This server seems great, but it is soooo frustrating trying to join, it says its running on 6.4.4, but when i switched to 6.4.4 and tried to join it said i needed an older version, so i went through and changed it to older and older for a while, until i got back to the first version, and it still says i need an older version! any help?