LemonCloud

Members
  • Content Count

    1
  • Joined

  • Last visited

  1. I install the launcher on my windows 10 acer computer (intel core 17) but it says "this application requires java environment 1.5.0 and does not launch PLEASE HELP