Jump to content

Mod Server Errors?

Recommended Posts


Unzipped a few mod files from the mods folder. I restarted the server and then got an error as such:

java.lang.NoClassDefFoundError: minecraft/server/mod_IC2 (wrong name: net/minecraft/server/mod_IC2)

    at java.lang.ClassLoader.defineClass1(Native Method)

    at java.lang.ClassLoader.defineClass(Unknown Source)

    at java.security.SecureClassLoader.defineClass(Unknown Source)

    at java.net.URLClassLoader.defineClass(Unknown Source)

    at java.net.URLClassLoader.access$100(Unknown Source)

    at java.net.URLClassLoader$1.run(Unknown Source)

    at java.net.URLClassLoader$1.run(Unknown Source)

    at java.security.AccessController.doPrivileged(Native Method)

    at java.net.URLClassLoader.findClass(Unknown Source)

    at java.lang.ClassLoader.loadClass(Unknown Source)

    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

    at java.lang.ClassLoader.loadClass(Unknown Source)

    at java.lang.ClassLoader.loadClass(Unknown Source)

    at java.lang.Class.forName0(Native Method)

    at java.lang.Class.forName(Unknown Source)

    at cpw.mods.fml.common.Loader.loadModClass(Loader.java:440)

    at cpw.mods.fml.common.Loader.attemptDirLoad(Loader.java:428)

    at cpw.mods.fml.common.Loader.attemptDirLoad(Loader.java:419)

    at cpw.mods.fml.common.Loader.attemptDirLoad(Loader.java:419)

    at cpw.mods.fml.common.Loader.load(Loader.java:357)

    at cpw.mods.fml.common.Loader.loadMods(Loader.java:527)

    at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBukkitHandler.java:113)

    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:118)

    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:426)

    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)


The rest of the error is here:


Would love some help on this. I Have looked through everything I can think of.



Link to comment
Share on other sites

Okay maybe that would be a start... I was just thinking that. Havnt slept in a while. :P Now the reason why I tried unzipping them was because when my players tried crafting items they wouldnt show up in the finished product box. Any suggestions?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...