Jump to content

Tekkit Server lag and max CPU with no players

Recommended Posts

I installed the Tekkit 3.1.1 server on a linux box with 2x2.7GHz processors and 4GB of RAM, and it was lagging terribly and using almost all of the CPU. It's unplayable with even one person logged on. Even with no one logged on, I kept getting the "Cant keep up" warning and my TPS was around 7. I even tried disabling all mods and plugins so I assume the only thing running was bukkit, and it still had the same problem. I'm using Oracle's Java 7, and tried OpenJDK as well but they both had the same issue. I tried a few different command line switches for java in the launch.sh to mess with the amount of memory used but that didn't have any effect, and the memory usage is low anyway, only around 200MB. I also tried regenerating a few different worlds to see if it was world specific but it had no effect. I should mention that the Tekkit server runs fine on my Windows machine which has less RAM and slower CPU's. Does anyone have any idea what's causing this? Is there some known Linux CPU issue on the version of bukkit that tekkit uses?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...