Jump to content

mod_ComputerCraft.cfg not reading? forge update fix?


Pugz
 Share

Recommended Posts

Hi there, new to the forums.

Just to state the server and our clients are running the 3.1.1 TechnicLancher update.

I am setting myself up with a rather over-featured reactor with all the bells and whistles but I came across a problem that should have been an easy fix, sadly this is not the case.

Ok so here is the problem..

I have two computers, one mainComp that is running the GUI for the options (one such option is to testAlarm). These computers are 22 blocks away thus my problem. The wiki states that "Modems can send messages to other modems located up to 64 metres away, or 17 metres during a thunderstorm."

A little odd how the world can be so big yet the range is so small? 17 blocks in rain? :S So I went about search through google and of course these and the computerCrafts forums and found this..

I think the problem is the forge version. There's was bug that makes it not read configs correctly.

Try using the latest recommended.

source: Link

I did post on there without thinking about the fact this is a Tekkit issue not a ComputerCraft issue :S /doh, but yeah onto the madness of this problem.

When I am standing at the mainComp and I set the program testAlarm running it will go through the motions but the receiving computer never gets the signal 22 blocks away rain or sun. Now this is the odd part, if I start the program testAlarm and then before the rednet.send() sends I run closer to receiving computer (5-8 blocks closer) the signal is received????? it's only 22 blocks away and even in the sun it needs me or a player to be 10-15 blocks away from it for it to receive??

The solution was easy, I needed a way to increase the range and I found one! with one of the ComputerCraft updates came a very handy mod_ComputerCraft.cfg that has the options to change the modem_range and modem_rangeSuringStorm. Here is the default config file..

#MLProperties: name (type:default) min:max -- information

#MLProp : computerBlockID (int:207)

#MLProp : diskDriveBlockID (int:208)

#MLProp : diskItemID (int:4000)

#MLProp : diskDriveGUIID (int:100)

#MLProp : enableAPI_http (int:0)

#MLProp : modem_range (int:64)

#MLProp : modem_rangeDuringStorm (int:1)

#

#Tue Jul 24 21:54:35 CEST 2012

terminal_width=50

terminal_textColour_g=255

modem_rangeDuringStorm=16

computerBlockID=207

diskItemID=4000

diskDriveBlockID=208

enableAPI_http=0

terminal_textColour_b=255

checksum=440

terminal_textColour_r=255

modem_range=64

diskDriveGUIID=100

terminal_height=18

As you can see the modem_range is 64 and modem_rangeDuringStorm is 17. I've changed those on both the server and my client to 500 and still nothing?

Anyone else having a similar issue? or maybe they wanted to change something else in the config and its not reading the changes?

Please help :D I have such amazing ideas but I don't want to have to put a console every 15 blocks to have to bounce a simple message :S

Thanks in advance peeps!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...