Jump to content

Cannot get Tekkit 2.1.0?


Recommended Posts


I downloaded an old Tekkit map, and it says that it only works in Tekkit 2.1.0 because, if I would load the map in 3.1.2 it would crash because of all the Forestry items that were in the modpack. So, I've been trying to downgrade to Tekkit 2.1.0 from the Technic Launcher, but it doesen't work. It only gives me a little pop-up saying ''Updating failed''. I've searched google through map converters for Tekkit but nothing worked. Help, please?

Link to comment
Share on other sites

  • 3 weeks later...

That didn't work for me. I've tried virtually everything, including rebuilding my computer, and trying to build it on different machines and copy it over.

I get the same popup telling me that the update 'failed', so I think it might be a problem with the website. Who knows...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...