Jump to content

Tekkit server uses all available ram instantly


alan_hayes
 Share

Recommended Posts

I've been running a tekkit server for me and my roomate, hoping to go large-scale someday soon, but there is a huge issue we can't figure out. I've spent hours on google, on this forum, looked at youtube videos that didn't help any, reinstalled Java 7u7 several times, downloaded a completely fresh tekkit server, and nothing seems to help at all. He's out of ideas as well. We're stumped.

Problem: Upon launching the Tekkit server with "java -Xmx5G -Xms3G -jar Tekkit.jar nogui --nojline pause" it jumps to 3 GB of RAM used and around 60-70% cpu usage. When one of us logs in the RAM use jumps to 5.3 GB and 95-100% CPU usage. Water doesn't flow down, lava doesn't either, and FPS is normally in the single digits. This is on my home server I've run multiple minecraft servers on at once with no problem in the past.

My home server specs:

Intel Dual Core E5700 @ 3.00GHz, 6GB 800 MHz RAM, Intel DQ45CB motherboard, and a freshly formatted 250GB Seagate. Running Windows Server 2008 R2 SP1, all updates and newest drivers installed.

Also I've run this on my desktop, which has:

AMD FX-4100 @ 4.01 GHz, 16 GB 1300 MHz RAM, Asus Crosshair V motherboard, Hitachi 2TB Sata 6 HDD, newest drivers as well. Although on my desktop I run "java -Xmx8G -Xms4G -jar Tekkit.jar nogui pause" Same RAM issue. I've run several games at the highest setting at the same time and never had lag, but running tekkit actually makes my system lock up and barely respond. This is quite annoying as Tekkit has some amazing mods I'd love to play around with.

Does anyone have any idea why this would happen?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...