Jump to content

Connection problems (LAN, mcmyadmin)


Recommended Posts

Hello,

I currently have have setup tekkit with mcmyadmin on a desktop on my local network. When i try to connect from a laptop connected through the wifi it times out saying "Failed to connect to server" and then below that "Connection timed out: connect"

i have tried with both firewalls turned on and off and checked that the router isnt blocking wifi connections to local wired connections.

this is the first time i have tried using mcmyadmin and i believe it is set up correctly (renaming the jar etc) as a tekkit client on the desktop (where the server is running) can connect and play.

weird thing is i can see the laptop packets arriving at the desktops network card using wireshark.

i have everything using default ports. i have entered the server address as the local ip of the desktop in both mcmyadmin and tekkits conf files.

i figure this must be something wrong with my setup or a default setting that shouldnt be set that way for my current setup. Anyone have any experience running tekkit with mcmyadmin?

most of the posts on the internet or here seem to have been answered by firewall or router settings.. is there something i missed checking?

Link to comment
Share on other sites

i have entered the server address as the local ip of the desktop in both mcmyadmin and tekkits conf files.

What do you mean by Tekkits conf files? Did you change "server-ip=" in "server.properties"? You should leave it blank unless you are 100% sure what you are doing. When it is left blank it binds to all IP addresses on your machine which you shouldn't normally change.

Otherwise, I haven't used mcmyadmin but it sounds like a firewall on the desktop computer is blocking the connection. You should try running a Vanilla server (easy as going to minecraft.net) or a regular Tekkit server and turn off the windows firewall or antivirus firewall to see if that works. Also triple-check that you are using the correct ports.

Link to comment
Share on other sites

Yea i did change that after it wasn't working. I have some adapters that are used for VMplayer and I had thought maybe they had bound to those IPs and not the one connected to my network. I will change it back and test again.

Ill double check the firewall again but currently it is turned off and even when on the mcmyadmin.exe is listed for allowing connections for both UDP and TCP protocols.

i did notice that when i look at the widget and the login screen on mcmyadmin that it lists the server as localhost but i can't for the life of me find anywhere else but the one place in the mcmyadmin conf file that lists a server ip address.

I think i will reinstall the whole thing. Start with just the vanilla minecraft and then move to tekkit. maybe i missed something in the initial setup that sets it up for remote access..

Thanks for the reply

Link to comment
Share on other sites

looks like my network adapter was somehow both classified under a home and public network. Thus the firewall i had turned off was only for the private connections (work and home) so it was in fact a firewall related issue. I figured it out after swapping the cord to a different jack on the back of the computer and it working without changing anything else.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...