Jump to content
  • 0

[SEVERE] Error occurred while enabling Factions v1.6.8 (Is it up to date?)


mirzakeehl
 Share

Question

Title: [sEVERE] Error occurred while enabling Factions v1.6.8 (Is it up to date?)

Version: 3.1.2

OS: Microsoft Windows XP Professional 32bit

Java Version: Java 7 u10

Description of Problem:

Faction error when I run the server.

Error Messages:

Error Log:

17:27:43 [iNFO] [Factions v1.6.8] === ENABLE START ===

17:27:43 [sEVERE] Error occurred while enabling Factions v1.6.8 (Is it up to dat

e?)

java.lang.AssertionError

        at com.google.gson.internal.bind.TypeAdapters$EnumTypeAdapter.<init>(Typ

eAdapters.java:686)

        at com.google.gson.internal.bind.TypeAdapters$24.create(TypeAdapters.jav

a:715)

        at com.google.gson.Gson.getAdapter(Gson.java:353)

        at com.google.gson.internal.bind.CollectionTypeAdapterFactory.create(Col

lectionTypeAdapterFactory.java:52)

        at com.google.gson.Gson.getAdapter(Gson.java:353)

        at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$1.<init>(R

eflectiveTypeAdapterFactory.java:82)

        at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory.createBoun

dField(ReflectiveTypeAdapterFactory.java:81)

        at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory.getBoundFi

elds(ReflectiveTypeAdapterFactory.java:118)

        at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory.create(Ref

lectiveTypeAdapterFactory.java:72)

        at com.google.gson.Gson.getAdapter(Gson.java:353)

        at com.google.gson.Gson.fromJson(Gson.java:754)

        at com.google.gson.Gson.fromJson(Gson.java:721)

        at com.google.gson.Gson.fromJson(Gson.java:670)

        at com.google.gson.Gson.fromJson(Gson.java:642)

        at com.massivecraft.factions.zcore.util.Persist.load(Persist.java:141)

        at com.massivecraft.factions.zcore.util.Persist.loadOrSaveDefault(Persis

t.java:84)

        at com.massivecraft.factions.zcore.util.Persist.loadOrSaveDefault(Persis

t.java:72)

        at com.massivecraft.factions.Conf.load(Conf.java:360)

        at com.massivecraft.factions.P.onEnable(P.java:86)

        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:215)

        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader

.java:337)

        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage

r.java:386)

        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:264)

        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:246

)

        at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:387)

        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:374)

        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:208)

        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)

        at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

17:27:43 [iNFO] Server permissions file permissions.yml is empty, ignoring it

17:27:43 [iNFO] Done (18.372s)! For help, type "help" or "?"

17:27:43 [iNFO] [Citizens] Unable to fetch player map from CraftEntity: players.

 Conflicting names will do funny things.

17:27:43 [iNFO] [Citizens] Loaded 4 NPCs.

17:27:43 [iNFO] [Railcraft] Loaded 0 saved Anchors

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I already try another version, like v1.7.5 BETA Factions, it works, but there is no Faction Tag when I'm chat.

-----------------------

On my second try is, I tried with the same version of Bukkit (Default Bukkit from Tekkit), with the same version of factions plugin (v1.6.8), it works fine, no error or anything.

-----------------------

Error update, when I try to use /f command in-game (the Factions is still error), it doesn't show anything, but there is something on the console.

[iNFO] [Factions v.1.6.8] Reset faction data <invalid faction. for player (name)

[WARNING] [Factions v1.6.8] Non existing factionId 0 requested! Issuing cleaning!

This error pop-ups when I type /f in-game.

Link to comment
Share on other sites

  • 0

Yes you can indeed, but don't expect any of the mod developers to know the codings of every plugin out there. It's not their job to do so. I didn't say you can't post it, i meant you would get better quality of help from the people who actually wrote this plugin. Mod developers might know but the probability of this is lower than the original author knowing his work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...