Jump to content

Looking for 1 Player to join a new private Tekkit Lite server


Recommended Posts

(EDIT) - we have added the mod Millenaire due to a popular vote, its simple instalation, and you will require it to be able to play on this server. They have there own website you can visit for instructions and links.

server holds 5 maximum (for now) which is why i only look for 1. we are mostly dedicated, quite new to tekkit but not minecraft, we will be playing on survival with the intention of co-op industrialisation!!

just created wolrd before i posted this so be quick and you wont miss much!

if your interested please fill this out;

ign (in game name) -

age -

mic -

availability -

experience -

optifine might be installed at a later date.


Link to comment
Share on other sites

ign - oblivion1818

age - 21

mic - Available

availability - 2pm - 1am Sunday-Wednesday, 8pm - 1am Thursday and Friday

experience - I have been playing minecraft for about 2 years and tekkit for a year and a half. I am familler with most of the mods with the exeption of railcraft however I am currently learning.

Link to comment
Share on other sites


age -15

mic -yep

availability -When ever

experience -1 year i know EE Ic2 Railcraft etc, but i am not so good with


Ender Storage

RedPower 2 ,

i know most of the pipes but not so much of the power

Link to comment
Share on other sites

EDIT: The version i use is 3.3.2 which is now outdated! If 4.0.0 is not working for you and you have followed my instructions then there is obviously a problem with the new Byzantines culture being added (maybe some block ID clashes) HOWEVER you can download the version i use, which works fine with this method of installation from here; http://millenaire.org/wiki/Version_History its at the top labeled 3.3 :) hope i helped!

Heres the steps i took;

-Start with a fresh tekkit lite folder (make sure you save any wolrds or rei's minimap waypoints, or anything else you want to keep)

(just delete the existing tekkitlite folder once youve backed up what you want and it will re-install when you next run it through the launcher)

-Visit ''http://millenaire.org/''

-I dont use the installer the develpoer provides.

-I downloaded the 3.3.2 version for minecraft 1.4.6 (client side)

-and the seperate download for 3.3.2 Minecraft Server 1.4.6 (server side)

-From now on the process for both client and server are excactly the same

-Open the zip file, open ''Millenaire 3.3.2'' folder, open ''Put In Mods Folder'', drag and drop the 3 files into the mods folder

(again this is exactly the same for sevrver and client)

You need it installed on BOTH server and client to work. It is a mod that changes how the world generates and as far as i am aware it will not regenerate chunks on a pre-generated world (like thaumcraft 3 does). Therefor using it on an old world will limit the village generation to only the areas unexplored in your world (as in uncovered on your map, un-generated chunks). So its best to create a new world once the mod is installed.

A few basics just incase you were unaware - dont leave the client or server running while modding. make sure the 3 folders end up in the /mods directory and havnt accidentally been dropped into a folder within the directory.

ANOTHER EDIT : What ammount of RAM is allocated to your Server / Client ? And also what details can you provide of the crash you get?

Link to comment
Share on other sites

Thanks for your thorough reply! I usually follow all the steps you listed on a regular basis as I'm always setting up new versions and testing them. Once I read your post I realized my error - I am using the client version for both server and client. I think I once did a comparison between the server and client downloads and found that they were the exact same file size (I forget which version, and for all I know it may not have been the same mod) so I didn't think using the same one for both would be a problem.

Strangely enough it does work, partially. My crashes happened every 15 minutes or so with the 0.5.1 version of Tekkit Lite, and now somehow with 0.5.2 they're only two or three times a day. I'm going to upgrade to version 4 and use the proper versions for server and client and see what happens.

Oh, and since you asked, I'm running Ubuntu Server on a machine with 4 GB of RAM and a core2duo 1.8ghz each processor. It's not fancy but it gets the job done, and fairly well considering I built it with spare parts.

EDIT: Still not working after a proper clean install and the right versions in the right places, and getting the same error too. My crash reports look like this:

Description: Exception in server tick loop


at java.util.HashMap$HashIterator.nextEntry(HashMap.java:894)

at java.util.HashMap$KeyIterator.next(HashMap.java:928)

at ii.a(EntityTracker.java:237)

at net.minecraft.server.MinecraftServer.r(MinecraftServer.java:692)

at ho.r(DedicatedServer.java:270)

at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:599)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:497)

at fy.run(SourceFile:849)

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...