Jump to content

Can´t connect to server?


Skarra94
 Share

Recommended Posts

I just finished setting up my own tekkit server and everything seemed to be going great, but when i was trying to connect to the server i got a meassage saying: "Firge Mod Loader could not connect to this server. The mods and versions listed below could not be found. The are required to play on this server.

I just downloaded the Tekkit pack and that is running on MC 1.5.1

I downgraded my MC to 1.5.1

I installed FML version 1.5.1 aswell (fml-universal-1.5.1-5.1.39.636)

I just get a long list of mods that doesn´t match.. Anybody know how to fix this?

I am running everything on Mac OS X 10.8.3

Link to comment
Share on other sites

I feel really stupid now.. figured it out two seconds after posting this.. but I got a new problem now.. MC won't launch because FML finds a couple of errors while loading and reffers me to the FML client log?

Link to comment
Share on other sites

I understand how to look at the log, but i can't seem to find the problem in the log.. This is where the errors start in the log:

2013-05-28 01:14:30 [iNFO] [sTDERR] Exception in thread "Thread-8" java.lang.RuntimeException: java.lang.NoClassDefFoundError: net/minecraft/block/Block

2013-05-28 01:14:30 [iNFO] [sTDERR]at cpw.mods.fml.relauncher.FMLRelauncher.setupHome(FMLRelauncher.java:192)

2013-05-28 01:14:30 [iNFO] [sTDERR]at cpw.mods.fml.relauncher.FMLRelauncher.relaunchApplet(FMLRelauncher.java:259)

2013-05-28 01:14:30 [iNFO] [sTDERR]at cpw.mods.fml.relauncher.FMLRelauncher.appletEntry(FMLRelauncher.java:229)

2013-05-28 01:14:30 [iNFO] [sTDERR]at net.minecraft.client.MinecraftApplet.init(MinecraftApplet.java:20)

2013-05-28 01:14:30 [iNFO] [sTDERR]at net.minecraft.Launcher.replace(Launcher.java:134)

2013-05-28 01:14:30 [iNFO] [sTDERR]at net.minecraft.Launcher$1.run(Launcher.java:78)

2013-05-28 01:14:30 [iNFO] [sTDERR] Caused by: java.lang.NoClassDefFoundError: net/minecraft/block/Block

2013-05-28 01:14:30 [iNFO] [sTDERR]at micdoodle8.mods.galacticraft.asm.GalacticraftPlugin.injectData(GalacticraftPlugin.java:133)

2013-05-28 01:14:30 [iNFO] [sTDERR]at cpw.mods.fml.relauncher.RelaunchLibraryManager.handleLaunch(RelaunchLibraryManager.java:289)

2013-05-28 01:14:30 [iNFO] [sTDERR]at cpw.mods.fml.relauncher.FMLRelauncher.setupHome(FMLRelauncher.java:172)

2013-05-28 01:14:30 [iNFO] [sTDERR]... 5 more

2013-05-28 01:14:30 [iNFO] [sTDERR] Caused by: java.lang.ClassNotFoundException: net.minecraft.block.Block

2013-05-28 01:14:30 [iNFO] [sTDERR]at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:238)

2013-05-28 01:14:30 [iNFO] [sTDERR]at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

2013-05-28 01:14:30 [iNFO] [sTDERR]at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

2013-05-28 01:14:30 [iNFO] [sTDERR]... 8 more

2013-05-28 01:14:30 [iNFO] [sTDERR] Caused by: java.lang.RuntimeException: Method not found: [apa.canBeReplacedByLeaves(Laab;III)Z]

2013-05-28 01:14:30 [iNFO] [sTDERR]at codechicken.core.asm.ASMHelper.alterMethods(ASMHelper.java:221)

2013-05-28 01:14:30 [iNFO] [sTDERR]at codechicken.core.asm.TweakTransformer.transform(TweakTransformer.java:179)

2013-05-28 01:14:30 [iNFO] [sTDERR]at cpw.mods.fml.relauncher.RelaunchClassLoader.runTransformers(RelaunchClassLoader.java:352)

2013-05-28 01:14:30 [iNFO] [sTDERR]at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:225)

2013-05-28 01:14:30 [iNFO] [sTDERR]... 10 more

Link to comment
Share on other sites

Didn't work, but i located the problem.. it's something to do with the mods i put in the client. Do i just copy the mods and coremods from the tekkit folders into the same folders in the client or is there something else i have to do?

Link to comment
Share on other sites

Looking at the NoClassDefFound errors, I think there is a mod in the coremods folder that needs to be removed if you are running it as a server. I will update this post when I can get home and take a look at which one it is.

Honestly though, it would be much easier to just use the server pack provided for tekket at http://www.technicpack.net/tekkit

Scroll to the bottom and just download the server pack where it says:

I used this as the base for my own server pack and added tinkerers construct, natura, mo creatures, and forrestry.

Link to comment
Share on other sites

Didn't work, but i located the problem.. it's something to do with the mods i put in the client. Do i just copy the mods and coremods from the tekkit folders into the same folders in the client or is there something else i have to do?

Basically, yes. The server and client must have the same mods. If you added mods to the mods/ folder on your client, you must also make sure those mods are installed in the mods/ folder on your server.

Link to comment
Share on other sites

i only have the tekkit mod pack installed on both server and client and i downloaded it from the technicpack site.. it's the first time i've tried to install mods on minecraft so i don't really know what to do

Link to comment
Share on other sites

Btw, thank you very much for the help, i'm new to mods and FML so i appreciate it

It's no problem, and it's my pleasure. We are all new to something. I have only been into mods for about 6 months and I am learning new things several times a day. As you pick up more and more, your google search terms get better and you can find answers quicker, but just starting out is rough, especially when you are having crashes.

I have a few questions to ask to try and narrow down the problem.

  1. Is your server up and running? can you type /help and get a response?
  2. What OS is your server running? My Technic Platform servers are all running Ubuntu 12.04 with Oracle Java 7.
  3. Have you tried starting fresh on both ends, deleting all the tekkit files from your server and re-downloading, and removing your .technic/tekkitmain/ folder then reinstalling it through the Technic launcher?
Link to comment
Share on other sites

  1. My server is up and running, no problems there. I actually tried connecting to it through the TechnichLauncher and it worked fine.
  2. I am running the server on my Mac with OS X 10.8.3 and Oracle Java 7
  3. I have tried reinstalling everything and also deleted everything and reinstalled it again (I only have worlds on other bukkit servers so I don't have a problem with deleting entire minecraft folders)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...