Jump to content

ID conflicts, but can't find correct config to fix them.


Recommended Posts

The Gist

Found ID conflict between Steel Dust and Axe Head (from Tinker's Construct), but can't find what config holds the Steel Dust ID, needed to change it. There's also a second ID that I have only identified as Copper Wire (not Copper Cable).

Does anyone know where the config is located that holds the Steel Dust (ID# 20444)?

Also, the game tells me ID# 1451 is Copper Wire, but I cannot locate that, nor do I know what other item it is conflicting with. If anyone knows the answer to this as well, I'd really appreciate it.

The Longer Version

Due to a world error, I unloaded Atomic Science and all 3 ICBM mods, to make the server boot up. But when I tried to log in on my client I got "ID mismatch between world and game", with the following two ID numbers: 20444 and 1451.

My server was kind enough to mention Tinker's Construct in relation to the error. Looking up TC's config file, I indeed found the ID - 20444 listed for Axe Head. I then created a fresh install, logged in and turned Show IDs to on. I located the item matching ID 20444 in the game and it is Steel Dust.

My Problem(s)

I cannot find what config holds ID# 20444, other than the one in Tinker's Construct. I know the game is telling me it is Steel Dust, but I've looked for a few hours and I simply cannot find an ID for Steel Dust.

I've tried changing ID 20444 in Tinker's Construct's config file with bad results. The first time I changed it on my server and client, it still kept telling me "ID mismatch", so I created an entirely new server, but added the changed config file for tinker's construct. It indeed started to boot up and did not give me that mismatch error, but it did tell me there was a "Missing Tinker's Construct ID" and it gave me the ID number of the Axe Head, that I changed it to.

There's also the issue of a second ID conflict that I've only managed to track down in-game, using the "Show Item IDs" function. It is ID# 1451, and, in-game, it tells me it is Copper Wire, so I've searched around in the configs and online. Looking online was not very helpful -- I kept getting results for Copper Cable, but not Wire.

I'm using Big Dig Server version 1.3.9

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...