Jump to content

Sound doesn't always seem start


TruePikachu
 Share

Recommended Posts

It seems to me that, numerous times (I thought this was related to addition of new mods in my install, but I'm not sure not), sound won't start with the game. Syntoms include not hearing that initial "click" sound, nor any other sounds. Sometime, it starts some time into the game, but not always.

For those interested, my current "pack" is at http://cdusto.selfip.com/technic/cDM-1.0.zip (I also have it on the Technic platform, mainly to help with multiplayer, but the core is Tekkit Lite, as is what _I_ launch.)

I've already seen if F3+S helps anything, it doesn't.

Any thoughts?

Link to comment
Share on other sites

After a bit of searching, I came across https://mojang.atlassian.net/browse/MC-11030 (Resolution: WAI)

This is because sounds are loaded asynchronously in the background. We may change this in the future' date=' but it will require a new launcher.[/quote']

The "launcher" in question is the old, 1.4.7-version launcher, not the 1.6 launcher.

Any information on improving the load times is appreciated. I'm about to also defrag my disk, just in case.

Link to comment
Share on other sites

Very interesting...

When it works:

[sTDOUT] Starting up SoundSystem...

[sTDOUT] Initializing LWJGL OpenAL

[sTDOUT]    (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)

[sTDERR] [LWJGL] getPathFromClassLoader: searching for: OpenAL32

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: sun.misc.Launcher$AppClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.net.URLClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.security.SecureClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] getPathFromClassLoader: searching for: lwjgl

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: sun.misc.Launcher$AppClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.net.URLClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.security.SecureClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] getPathFromClassLoader: searching for: lwjgl

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: sun.misc.Launcher$AppClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.net.URLClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.security.SecureClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Found 8 OpenAL paths

[sTDERR] [LWJGL] Testing 'C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL64.dll'

[sTDERR] [LWJGL] Found OpenAL at 'C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL64.dll'

[sTDOUT] OpenAL initialized.


 

When it doesn't:


[sTDOUT] Initializing LWJGL OpenAL

[sTDOUT]     (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)

[sTDERR] [LWJGL] getPathFromClassLoader: searching for: OpenAL32

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: sun.misc.Launcher$AppClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.net.URLClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.security.SecureClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] getPathFromClassLoader: searching for: lwjgl

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: sun.misc.Launcher$AppClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.net.URLClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.security.SecureClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] getPathFromClassLoader: searching for: lwjgl

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: sun.misc.Launcher$AppClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.net.URLClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Failed to locate findLibrary method: java.lang.NoSuchMethodException: java.security.SecureClassLoader.findLibrary(java.lang.String)

[sTDERR] [LWJGL] Found 8 OpenAL paths

[sTDERR] [LWJGL] Testing 'C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL64.dll'

[sTDERR] [LWJGL] Found OpenAL at 'C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL64.dll'

(OpenAL)  AL lib: (EE) MMDevApiOpenPlayback: Device init failed: 0x80004005

(OpenAL)  AL lib: (EE) MMDevApiOpenPlayback: Device init failed: 0x80004005

(OpenAL)  AL lib: (EE) MMDevApiOpenPlayback: Device init failed: 0x80004005

[sTDERR] [LWJGL] Failed to load C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL64.dll: Could not open ALC device

[sTDERR] [LWJGL] Testing 'C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL64.dll'

[sTDERR] [LWJGL] Found OpenAL at 'C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL64.dll'

[sTDERR] [LWJGL] Failed to load C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL64.dll: Could not open ALC device

[sTDERR] [LWJGL] Testing 'C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\OpenAL64.dll'

[sTDERR] [LWJGL] Failed to load C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\OpenAL64.dll: Could not load OpenAL library (126)

[sTDERR] [LWJGL] Testing 'OpenAL64.dll'

[sTDERR] [LWJGL] Found OpenAL at 'OpenAL64.dll'

[sTDERR] [LWJGL] Failed to load OpenAL64.dll: Could not open ALC device

[sTDERR] [LWJGL] Testing 'C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL32.dll'

[sTDERR] [LWJGL] Failed to load C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL32.dll: Could not load OpenAL library (193)

[sTDERR] [LWJGL] Testing 'C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL32.dll'

[sTDERR] [LWJGL] Failed to load C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\bin\natives\OpenAL32.dll: Could not load OpenAL library (193)

[sTDERR] [LWJGL] Testing 'C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\OpenAL32.dll'

[sTDERR] [LWJGL] Failed to load C:\Users\Chris\AppData\Roaming\.technic\tekkitlite\OpenAL32.dll: Could not load OpenAL library (126)

[sTDERR] [LWJGL] Testing 'OpenAL32.dll'

[sTDERR] [LWJGL] Failed to load OpenAL32.dll: Could not load OpenAL library (193)

[sTDOUT] Error in class 'LibraryLWJGLOpenAL'

[sTDOUT]     Unable to initialize OpenAL.  Probable cause: OpenAL not supported.

[sTDOUT]     ERROR MESSAGE:

[sTDOUT]         Could not locate OpenAL library.

[sTDOUT]     STACK TRACE:

[sTDOUT]         org.lwjgl.openal.AL.create(AL.java:151)

[sTDOUT]         org.lwjgl.openal.AL.create(AL.java:102)

[sTDOUT]         org.lwjgl.openal.AL.create(AL.java:201)

[sTDOUT]         paulscode.sound.libraries.LibraryLWJGLOpenAL.init(Unknown Source)

[sTDOUT]         paulscode.sound.SoundSystem.CommandNewLibrary(Unknown Source)

[sTDOUT]         paulscode.sound.SoundSystem.CommandQueue(Unknown Source)

[sTDOUT]         paulscode.sound.CommandThread.run(Unknown Source)

[sTDOUT]     ERROR MESSAGE:

[sTDOUT]         Could not locate OpenAL library.

[sTDOUT] Starting up SoundSystem...

[sTDOUT] Switching to No Sound

[sTDOUT]     (Silent Mode)

There are no configuration changes between these different launches.

In case anyone is wondering why I keep posting as I find things, it is both so that the most recent information is availible, and so that there are more things that search functions (both forum-based and Google) can pick up on, to hopefully help other people with similar problems fix them, basically to avert XKCD/979

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...