Jump to content

[TekKit] Almost any Bukkit plugins won't work

Recommended Posts


First some information of my machine which is running the TekKit server:

- Very last Java version (7.xxxxx)

- Windows 7 Ultimate x64

- 4 GB ram

I'm using Tekkit for a couple of days now and would like to add a few Bukkit plugins (I hate creepers, eg.). First I tried to add WorldGuard, which give's me this error. I don't mind which plugin nerf's the creepers, so next I downloaded http://forums.bukkit.org/threads/mech-safe-creeper-1-0-1-control-creepers-enderman-tnt-fireballs-and-more-1-2-5.25253/"]Safe Creeper 1.0.1. This plugin seems to run fine, I can use the command's, but it doesn't do anything further (and I'm sure I configured it correctly). Could be a bug in the plugin, so I tried another one: AntiCreeperV3. When a creeper explodes, I get this error message. I could give you more examples, but I guess I made my message pretty clear. All of this plugins just work's fine on a normal CraftBukkit server (Yes, I tested :)), so the problem is defiantly TekKit.

Am I doing anything wrong, is this a bug in tekkit? Has it to do with the versions? Any solution would be greatly appreciated!

Thanks in advance,


Edit: I forgot to mention CommandBook, ChopTree, PermissionEx, RecipeManager and WorldEdit are running perfectly.

Link to comment
Share on other sites

You have to use plugins made for craftbukkit 1.1-R4, not for the most recent version.

That's sucks a bit, but will do the trick. Thank you very much!

I used MantaMobControl for mine. It lets you decide which mobs spawn or not. But sct is correct, you need to match versions.

Thanks for your response as well! I will take a look at MantaMobControl too.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...