Jump to content

Another Mac-Technic problem fixed


Valduane
 Share

Recommended Posts

Background

I have played Minecraft and Tekkit for a couple years now on and off on 2 separate MacBooks through various iterations of OSX and various iterations of Java and have experienced a lot of the default Mac-Technic-Java compatibility issues each time I did a reinstall on a new hard drive, or changed Laptops. 

 

Today however I came across a new problem for which I gathering info and planning to post on this forum, when I eventually stumbled across "my solution".

 

On my 1 macbook, I had prepared it (very poorly) for return to work before they decided I could keep it. In doing this I simply deleted the techniclauncher.jar file. Now months on after a bit of Vanilla MC with my sons, we have once again set up a Tekkit server and decided to have a go at getting to the Moon.

 

Problem

  • Newly downloaded techniclauncher.jar file would do nothing.
  • Copied techniclauncher.jar file from my other Macbook (which was running Technic fine) would show the Technic loading splash image, then fail to open the Launcher Window.

Solution

While trawling the millions of solutions posted on this forum, youtube and various other forums that Google found, I remembered that on first run, the launcher dumps files into a technic folder in the User/Libriary/Application Support/ folder where you place texture packs etc and I wondered whether I had left those on this laptop and perhaps there was some version conflict between the new build and my OLD technic files as the Launcher started to load and referenced those files.

 

So I relabelled the folder as technic_backup and tried the launcher again. After the loading splash screen it warned me that there was no technic folder and that it would create 1. I said yes....

 

TADA!! Fixed!

 

Hope this helps someone else who might be in the same situation I am.

 

ValDuane

Link to comment
Share on other sites

Good to hear you solved it. Removing the entire installation (saving worlds first, of course) and installing clean is always the last option to resolve an issue.

Edited by Curunir
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...