Jump to content

Singleplayer world keeps crashes when I launch it.

Recommended Posts

I've been playing Attack of the B-Team for a while now but have never come across this before. When I launch my singleplayer world it at first said that there was an error in galacticraft and crashed, so since i don't use that mod at all i deleted the file. I tried again to launch it again but it crashed again and said that there wasn't enough memory. I have 10gb of ram on my computer and have the technic launcher set to 6gb. I restarted the launcher and tried to launch it again and i got this:


[b#439]  2014-07-04 19:38:36 [iNFO] [sTDOUT] Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
[b#439]  2014-07-04 19:38:36 [iNFO] [sTDOUT] #@!@# Game crashed! Crash report saved to: #@!@# C:Program FilesTechnicmodpacksattack-of-the-bteamcrash-reportscrash-2014-07-04_19.38.36-client.txt
[b#439]  AL lib: (EE) alc_cleanup: 1 device not closed
[b#439]  Picked up _JAVA_OPTIONS: -Xmx512M
[b#439] Maximum usable memory detected: 9674 mb
The last line is from after it closed I checked the Ram settings again. I don't know what Vec3 Pool Size means or how to allocate more memory to it.
Help would be greatly appreciated!
Link to comment
Share on other sites

This is overriding the memory to a maximum of 512MB: -Xmx512M


It'll be in system environment variables, look in there for the _JAVA_OPTIONS entry that has that -Xmx switch in it and remove it.


In future if you have this kind of trouble post up on the Tracker rather than here for assistance and advice (there's a link in my sig), that 'galacticraft' crash was most likely a conflict between morph and enhanced portals, but because galacticraft does things with entities in the game its name shows up (the only difference removing galacticraft would have if I'm correct about the cause is that you'll now get a normal minecraft entity being reported in the error rather than a galacticraft one).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...