Jump to content

Everything portforwarded correctly yet my friends still cannot join? baffled.


Recommended Posts

Hi all,

 Sorry if this is in the wrong section but I've not posted here many times before.

 Basically I have had a tekkit server for around 18months and I haven't played since Christmas, I started playing again this week I updated the client on tuesday and downloaded the most recent server files also. My ip had changed and I gave this to my friends who were joining the server and after a lot of faffing around I managed to get it working and we all joined it.

 However last night neither of my friends could join the server, the server is opened for me (using the ipv4 address) but not if i use my ip found by typing "What's my IP into google". I factory reset my router, gave my friends the new ip that was generated and still nothing, I deleted the portforwarding settings and re-forwarded them and still nothing, turned off the firewall settings and then that seemed to work for a little while before it then kicked them both off again. I followed all the prior steps again and nothing worked this time round.

Today I logged in by myself and the server still works for me but if i try and access it via the other IP it didn't work so I turned off windows firewall and hey presto it worked for me. Now a few hours later and my brother wants to join but it keeps telling him that he cannot reach the server. I've switched between both the windows and router firewalls being on and off, redone the portforwarding settings, tried to set Tekkit to be allowed through the windows firewall, redownloaded the server files and as a long shot redownloaded the entire technic pack too and I still have nothing.


If it helps at all my server whenever i click anything in the multiplayer menu spazzes out with the message:


2014-08-01 18:45:48 [sEVERE] [Minecraft-Server] Reached end of stream for /

Anyone have any ideas? I'm supposed to be recording tonight and I can't due to this stupid problem.

Additional notes:

Whitelisting is disabled, the server-ip= in server properties is empty, my pc is connected via an ethernet cable (so no change there), the router in question is a BT Homehub 3 (fibre optic) and the only other things connected to the internet are via wifi and they are a nokia lumia 1020 and a 3DS



any ideas what could be causing this? I'm completely stumped.

Edited by Collymog
Link to comment
Share on other sites

hmmmm I just set online mode to false in server properties and this seems to have solved the problem - for now I'll keep this post informed and see if it lasts.

But if anyone else has any ideas to what might cause it then feel free to let me know :)

Link to comment
Share on other sites

Issues belong on the tracker, and there is a template you should follow to make them readable.


But since this one is simple: Mojang has been having server hiccups recently, which will result in bad logins and is entirely unrelated to which Minecraft flavour or modpack you are trying to use. If such issues occur, you can check with Mojang, or here, for server status.


You can make your server independent from Mojang logins with the option online-mode=false, as you already found out. This will simply cause your server to never check with Mojang if an account is legit. You will be running what is sometimes called a "hacked server", although it is a regular option that was put there by Mojang themselves. Forfeiting that check will allow players to join during such outages, but will also allow unauthorized (=pirated) clients to join. If you're just playing with friends, it should not matter too much. Maybe use a whitelist to be safe.


Apart from that, you always need to make sure that your server and clients have matching versions of all included mods, but that is covered if you use official Tekkit builds.

Edited by Curunir
Link to comment
Share on other sites

Hello Again, thanks for the reply, The server is broke again my brother got an hours play on it before it booted him off and he can't get back on. the server status stuff you posted says everything is working ok. as for matching versions both tekkit and my server to my knowledge are both the same version.

Maybe there'll be a fix to this soon I don't know it's so frustrating.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...