Jump to content

Tekkit server running really slow.

Recommended Posts

So I intalled tekkit on my dedicated yesterday, everything worked good and we had a good time, but when I woke up this morning.....

At my house all the machines and the quarry works at 10% speed and everything generally is very slow and when I tried walking over to my friends house my fps started dropping down to about 0.5 fps and got crazy amounts of lag.

Any suggestions to what could be the cause, or any fixes for it?

Link to comment
Share on other sites

Did you leave your quarry running and was it connected to Buildcraft pipes? The quarry will continue to run after you log off but the pipes will not function when the chunk is unloaded. Blocks will be dropped on the ground causing a lot of lag in the area.

Does the lag exist everywhere? When I had problems with a large amount of blocks on the ground, the lag only existed in a ~100 block radius of the spilled blocks.

I would suggest looking around the quarry/pipes for a bunch of blocks on the ground.

I would also suggest that you shut your quarries off until you identify the source of the lag, you don't want to make the problem worse if they turn out to be the cause.

Link to comment
Share on other sites

Items on the ground generate FPS lag when it reaches a certain number. We usually refer to it as a "leaky machine". A setup that dont have enought "overflowprotection" will generate FPS-drops of whoever loads that area. Eighter get worldedit to remove those items, or just be more carefull on how machines are set up.

Link to comment
Share on other sites

Wait, my quarry with buildcraft pipes run just fine when no one is logged on.

I worded my post poorly. What I meant was that Buildcraft pipes drop stuff at chunk borders if the chunk is unloaded, at least they do in my experience.

We had a long line of pipes and items would only be transported about halfway before they fell on the ground unless someone was running along the pipes. I assume this is because the chunk was unloaded as they worked fine when standing next to them.

Link to comment
Share on other sites

Regarding the /remove items -1 command... it works a treat...

However, can anybody tell me what mod/component it is in Tekkit that allows the use of this command? Anybody know its permission?

I would love to give this permission out to several people, but don't wish to OP everyone to grant them the ability...


Edit: Think I have just found the answer to my own question... WorldEdit ;) I am guessing the permission would be "worldedit.remove"

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...