Jump to content



Recommended Posts

Ok so, I tried Installing InfiTools for Tekkit. Here's what I did:

1. Went to the page for Bukkit ports -> http://mcportcentral.co.za/wiki/index.php?title=Ports_for_1.2.5

2. Dropped the files from InfiBase in my Craftbukkit.jar

3. Dropped the files from 4016 Block ID fix in my Craftbukkit.jar

4. Put the InfiTools-Core-Bukkit.zip in my server/mods/ folder

5. Dropped the client zip of InfiTools in my Tekkit/mods/ folder

6. Fired up my server and client

7. Server loads up successfully, showing that all mods have loaded -> http://puu.sh/BxES

8. Tried joining, works.

But as soon as I try and craft something that requires InfiTools, I get the error "java.lang.NullPointer.Exception" and my server window says "disconnect.endOfStream"

(also NEI doesn't show any of the new items)

I've also tried dropping the contents of InfiTools-Core-Bukkit.zip into the Craftbukkit.jar directly, same thing.

What's also weird is that I can join the server without actually requiring InfiTools on my client. Normally it should tell me that I'm missing the InfiTools mod, this isn't the case here.


Thanks in advance ;<

Link to comment
Share on other sites

Dropping files in Craftbukkit.jar is a bad habit. I think that's your problem here, not sure. I let these kind of mods alone. But keep in mind that Tekkit is a heavy modded craftbukkit and chances are that you did ovewrite some of the modifications now. It may be appearing to work, but in fact it's broken under the hood. It's very tricky what you are trying to do here...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...