Jump to content

Issues with Tekkit Server 3.0.4

Recommended Posts

I recently tried starting a Tekkit Server, I watched tutorials and guides and such and have hosted many servers in the past. I get this strange error when trying to launch the tekkit server, something about nether ores? I'll post it:

C:\Users\Sean\Desktop\Tekkit Server>java -Xmx3G -Xms2G -jar Tekkit.jar nogui

182 recipes

27 achievements

17:15:21 [iNFO] Starting minecraft server version 1.2.5

17:15:21 [iNFO] Forge Mod Loader version @MAJOR@.@MINOR@.@REV@.@BUILD@ for Minec

raft @MCVERSION@ loading

17:15:21 [iNFO] Loading mods from C:\Users\Sean\Desktop\Tekkit Server\mods

17:15:21 [sEVERE] java.lang.UnsupportedClassVersionError: net/minecraft/server/m

od_NetherOres : Unsupported major.minor version 51.0

17:15:21 [sEVERE] at java.lang.ClassLoader.defineClass1(Native Method)

17:15:21 [sEVERE] at java.lang.ClassLoader.defineClassCond(Unknown Source)

17:15:21 [sEVERE] at java.lang.ClassLoader.defineClass(Unknown Source)

17:15:21 [sEVERE] at java.security.SecureClassLoader.defineClass(Unknown S


17:15:21 [sEVERE] at java.net.URLClassLoader.defineClass(Unknown Source)

17:15:21 [sEVERE] at java.net.URLClassLoader.access$000(Unknown Source)

17:15:21 [sEVERE] at java.net.URLClassLoader$1.run(Unknown Source)

17:15:21 [sEVERE] at java.security.AccessController.doPrivileged(Native Me


17:15:21 [sEVERE] at java.net.URLClassLoader.findClass(Unknown Source)

17:15:21 [sEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)

17:15:21 [sEVERE] at sun.misc.Launcher$AppClassLoader.loadClass(Unknown So


17:15:21 [sEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)

17:15:21 [sEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)

17:15:21 [sEVERE] at java.lang.Class.forName0(Native Method)

17:15:21 [sEVERE] at java.lang.Class.forName(Unknown Source)

17:15:21 [sEVERE] at cpw.mods.fml.common.Loader.loadModClass(Loader.java:4


17:15:21 [sEVERE] at cpw.mods.fml.common.Loader.attemptFileLoad(Loader.jav


17:15:21 [sEVERE] at cpw.mods.fml.common.Loader.load(Loader.java:375)

17:15:21 [sEVERE] at cpw.mods.fml.common.Loader.loadMods(Loader.java:527)

17:15:21 [sEVERE] at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBuk


17:15:21 [sEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftSe


17:15:21 [sEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftSer


17:15:21 [sEVERE] at net.minecraft.server.ThreadServerApplication.run(Sour


17:15:21 [sEVERE] Unexpected exception

java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_NetherOres : Un

supported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(Unknown Source)

at java.lang.ClassLoader.defineClass(Unknown Source)

at java.security.SecureClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.access$000(Unknown Source)

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Unknown Source)

at cpw.mods.fml.common.Loader.loadModClass(Loader.java:440)

at cpw.mods.fml.common.Loader.attemptFileLoad(Loader.java:497)

at cpw.mods.fml.common.Loader.load(Loader.java:375)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:527)

at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBukkitHandler.java:


at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:118)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:426)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)


Well, there you go. If you have any idea whats wrong and if I can fix it, please let me know.

Link to comment
Share on other sites

Ok I think I see where the problem was. I had 6 different versions of Java on my computer (I used to do a lot of Java stuff back in the day LOL) so I deleted them all, and installed the newest version of Java 7 x64. I looked at my enviromental variables, and the "PATH" one was set to a very old version of Java. I fixed the enviromental variables and now it worked. Let this be a lesson to all you others having issues out there. I'll lock this thread.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...