Jump to content

Odd Glitch with lava not moving/spreading [Image included]

Recommended Posts


On a tekkit server, I made an automated cobblestone generator using block breakers- You can see how it works by looking at the imagetekkitlava.png

(note there are 2 rows of cobble generators shown)

Essentially, the block breaker would sit next to the dirt block, with the idea that the water and lava create cobblestone where the line of grass is in between the water and lava. The block breaker (which is on a clock from the wireless receivers) break the cobble, then the obsidian pipes suck it up and take it away.

I had it on a clock from a computer, with the program "redpulse" with a period of 2s. It worked fine for about 30 mins, then all of a sudden this happens. The lava will simply not spread anymore. It will take about a full minute for any single piece of cobble to be created now.

I have tried replacing the lava and water sources, and the block breakers, however the lava will still not spread. Is this a glitch?

Thanks for the help

Link to comment
Share on other sites

  • 2 weeks later...

I have had the exact same thing happen to me.

Another guy on the server has the same thing happen to him.

No matter what you do it just does not work again.

You actually have to rebuild the cob gen miles away for it to work again.

This is a pain becuase I run a 120 block breaker cobble gen (12 BB long in 10 lanes). To make enough scrap for my mass fab.

Moving that factory is not a joke.

So if anybody has a fix for this or if the developers know how we can prevent this from happening please do tell.

Link to comment
Share on other sites

  • Moderators

This "bug" is caused by too many fluid updates for the game to handle, and then the affected chunks all start having flow issues.

Also, man, you don't need all that. Just this.


Also, cobble gens are bad in general, even the most effecient systems will cause alrge amounts of lag if used en masse.

Link to comment
Share on other sites

Good input Jusupov, thanks a bunch for that mate. Maybe on your server this kind of thing will lag you up. that doesn't mean it will on mine.

Anyway I've narrowed it down to using the world anchors. As soon as you place a world anchor then let the chunk be held in place using it, it will stop spreading as shown, so avoid them. It will actually permanently screw up that chunk it seems, and the only way to fix it is to move it.

Thanks maiden, but I've already made a new design. Compact 4 x 8 version that uses a computer to calculate the EMC generated, diamonds generated and control timing signals ;)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...