Jump to content

Ender Chests

Recommended Posts

I know this should be in Bug Report, but for some reason it tells me i have insufficient privileges to post there.

I run a Tekkit Server. I made and placed an Ender Chest, then i was gonna activate it, when server crash.

Now every time i try to run it, it tells me:

15:29:58 [iNFORMACIËN] Done (6,201s)! For help, type "help" or "?"

15:29:59 [iNFORMACIËN] [Railcraft] Loaded 0 saved Anchors

15:29:59 [GRAVE] java.lang.ClassCastException: net.minecraft.server.NBTTagEnd ca

nnot be cast to net.minecraft.server.NBTTagCompound

15:29:59 [GRAVE] at codechicken.enderstorage.EnderStorageManager$EnderSto


15:29:59 [GRAVE] at codechicken.enderstorage.EnderStorageManager$EnderSto


15:29:59 [GRAVE] at codechicken.enderstorage.EnderStorageManager.getStora


15:29:59 [GRAVE] at codechicken.enderstorage.TileEnderChest.q_(TileEnderC


15:29:59 [GRAVE] at net.minecraft.server.World.tickEntities(World.java:11


15:29:59 [GRAVE] at net.minecraft.server.MinecraftServer.w(MinecraftServe


15:29:59 [GRAVE] at net.minecraft.server.MinecraftServer.run(MinecraftSer


15:29:59 [GRAVE] at net.minecraft.server.ThreadServerApplication.run(Sour


15:29:59 [GRAVE] Unexpected exception

java.lang.ClassCastException: net.minecraft.server.NBTTagEnd cannot be cast to n


at codechicken.enderstorage.EnderStorageManager$EnderStorageInv.loadItem


at codechicken.enderstorage.EnderStorageManager$EnderStorageInv.<init>(E


at codechicken.enderstorage.EnderStorageManager.getStorage(EnderStorageM


at codechicken.enderstorage.TileEnderChest.q_(TileEnderChest.java:66)

at net.minecraft.server.World.tickEntities(World.java:1191)

at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:547)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:453)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

15:30:46 [iNFORMACIËN] Connection reset


And no one can join. Help please.

Link to comment
Share on other sites

  • 4 weeks later...

You seem to be the only person I have found with the same issue. With tekkit 3.1.2, I placed an enderchest and when I tried to open it, crashed the server. I seem to have corrupted the world file, since the world wont load in previous versions of tekkit or with Tekkit SSP. So far, we have tried:

Reloading Server

Restarting Server

Loading world in 3.1.1 and some older versions

Loading world in Tekkit SSP (3.1.2)

Loading world in Tekkit SSP (3.1.1)

Deleting the File located in "World>EnderStorage>0.dat: We deleted this file, which allowed us to access the server, but the block was still there. Upon removal of the block, the server crashed again.

MCEdit: We loaded the world with MCEdit and removed the "FutureBlock EnderChest" with MCEdit for 1.2.5. We then ran the server (3.1.2) and the block was gone. This fixed the problem but occasionally caused some lighting glitches.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...