Jump to content

Friend can't join tekkit server


Wakigo
 Share

Recommended Posts

Try port forwarding on your router, find your public IP, give your friend that and see if it works. Make sure you set up the port forwarding first, its usually pretty simple to do, depending on your router.

Link to comment
Share on other sites

Try port forwarding on your router, find your public IP, give your friend that and see if it works. Make sure you set up the port forwarding first, its usually pretty simple to do, depending on your router.

I don't know how to port forward :/

Link to comment
Share on other sites

Need more info. What have you tried?

I tried having her join with localhost as server address which didn't work, I tried Hamachi and it didn't work either... I don't know any other ways of trying except port forwarding and I have no idea how to

Link to comment
Share on other sites

I tried having her join with localhost as server address which didn't work, I tried Hamachi and it didn't work either... I don't know any other ways of trying except port forwarding and I have no idea how to

localhost means log into your own computer.

If you can't get hamachi to work, port forwarding is the only real way to go. It's not hard, just look at the instruction book for your router, log into it, and go to port settings. Forward port 25565 TCP and UDP to your computer and that's it. There are also many applications that run scripts to do it for you if you put in the make and model of your router but it's simple enough that you should be able to do if you're running a server.

Link to comment
Share on other sites

localhost means log into your own computer.

If you can't get hamachi to work, port forwarding is the only real way to go. It's not hard, just look at the instruction book for your router, log into it, and go to port settings. Forward port 25565 TCP and UDP to your computer and that's it. There are also many applications that run scripts to do it for you if you put in the make and model of your router but it's simple enough that you should be able to do if you're running a server.

Okay so I did something in hamachi that changed the ipv4 address to the hamachi one and I don't know how to undo... i downloaded a program that did the port forward and it has a test thing that says it works. So Any idea how to change it back?

Link to comment
Share on other sites

You may have not stopped the other server properly. Try restarting your computer.

If you're intent on using hamachi, this is where my help ends because I won't be able to provide any unless it's for general server problems.

Link to comment
Share on other sites

You may have not stopped the other server properly. Try restarting your computer.

If you're intent on using hamachi, this is where my help ends because I won't be able to provide any unless it's for general server problems.

No I'm trying to use the port forward which the program i got says it's ready to use and working. I just have to get the damn server launch working x.x i restarted, turn internet off and on, shut computer for 2 hours, and nothing... still says it's up

Link to comment
Share on other sites

In that case, I would post this as a bug report with all the necessary logs on the Tekkit SMP Bug forum because that's an error I can kind of understand but I'm not familiar with it and I don't know how to fix it. The eggheads in the bug forum should have better luck if you provide them all the information they need.

Link to comment
Share on other sites

In that case, I would post this as a bug report with all the necessary logs on the Tekkit SMP Bug forum because that's an error I can kind of understand but I'm not familiar with it and I don't know how to fix it. The eggheads in the bug forum should have better luck if you provide them all the information they need.

so I got the thing to use another port and now it says the connection to it is working, and tekkit server bat thing goes to railcraft which people tell me means you can make a server by then, i make one with the ip but now it says it cant reach server in tekkit...

Link to comment
Share on other sites

She got it and still timed out and failed connection... and sorry about spelling :P

Re you both on the same channel, and re you the host in hamachi?

Also there may be some main computer program using it.

Try changing the port in Server.properties

Link to comment
Share on other sites

Re you both on the same channel, and re you the host in hamachi?

Also there may be some main computer program using it.

Try changing the port in Server.properties

Well now the problem is no matter what port i use, it says something is already being hosted in it....

Link to comment
Share on other sites

Make sure server-port is set to default in your server.properties file and make sure server-ip is blank, then try restarting the server and send me the server.log file after.

If you set server-ip it forces the server to bind to only 1 network interface, also, if you type the wrong IP here the server will not be able to bind to any internface resulting in the message above. You should never need to bind your server to a specific IP unless your running more than 1 tekkit server on the same computer. By leaving server-ip blank, you're telling the server to accept connections from all interfaces including Hamaci.

I run a server that you can connect to with or without Hamachi. You shoudn't need to forward ports if your using Hamachi because it makes a network tunnel between the server and the client bypassing the NAT forwarding on your router. If you need more help setting up Hamachi let me know.

Also, make sure you type stop into the server console to close your server before restarting it.

EXAMPLE server.properties:

#Minecraft server properties

#Fri Aug 03 03:31:46 EDT 2012

allow-nether=true

level-name=world

enable-query=false

allow-flight=true

server-port=25565

level-type=DEFAULT

enable-rcon=false

level-seed=

server-ip=

max-build-height=256

spawn-npcs=true

white-list=false

spawn-animals=true

online-mode=true

pvp=true

difficulty=1

server-name=Unknown Server

gamemode=0

max-players=20

spawn-monsters=true

view-distance=10

generate-structures=true

motd=Tekkit 3.1.2

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...