Jump to content
  • 0

Frame Rate issues



To make a long story short, any large modpacks I play which includes the Blightfall modpack, The instant I get to the main menu The framerate just drops. Since I cant fix the Framerate its making it almost impossible to play any modpacks above like 30-40 modpacks. I can play things such as tekkit classic but I cant play hexxit, blightfall or Tekkit (current).

What OS are you using? I'm using Windows 10

What version of JAVA do you have? Unknown

Are you using 64bit or 32bit architecture? I have both accessible but neither reduces the problem

What processor is in your PC? Intel core i7 (or might be Nvidia Geforce not sure)

How much physical memory does your PC have? 16gb 12gb available as of right now

How much memory are allocating in the launcher? I've tried anywhere from 1/2gb to 11gbs

What other applications are open while trying to run the launcher/modpack? Nothing, I close them all while its up in attempts to fix the issue

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

What is the model of your graphics card? If you are using a laptop, it's likely the onboard graphics is having a hard time with the larger modpacks. Another laptop-related issue may be that temperature controls or power saving mode is reducing the maximum processing power you can devote to the game. 

Find out what version of Java you are using. Try uninstalling all versions of Java on your computer, and then re-install just the most recent 64-bit version of Java.

Have you tried reducing the render distance to minimum? What is the effect on your frame rate?

Try turning off Fancy graphics, setting Lighting detail to off, and disabling ground blending. What is the frame rate before and after these changes?

Are your graphics drivers up to date? If your laptop came with Windows 8 and you updated to Windows 10, it might be possible you need to get an updated driver for your graphics card.

If you can play lighter modpacks and your PC slows down with larger ones, it's also very likely your PC just can't handle them. I would think that with an i7 it should work, though. I am using only an i5 on my desktop and I have no issues playing Blightfall, but I also have a dedicated graphics card.

If your frame rate is slow or choppy, it usually indicates an issue with your graphics processor. If you are using a laptop, it may be impossible to upgrade or repair this component. The best advice I can offer you is to make sure your graphics drivers are up to date by obtaining the most recent drivers from nvidia's website. At a glance it would appear your PC should support these modpacks.

Also, Blightfall (and all other official technic modpacks as of today) should run fine on 3GB of RAM. It will not make the frame rate any faster to give it more - in fact, it might even slow you down more. Focus on the steps suggested here.

Link to comment
Share on other sites

  • 0

Listen to DoctorDharok. You can also try adding Fastcraft to Blightfall. Check if it helps, if not - remove it.

Apart from the view distance setting you can disable clouds in the options and you can experiment with the advanced opengl setting in options.txt

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...