• 0
Sign in to follow this  
ramdor

Redpower timer animation stutter

Question

Title: Redpower timer animation stutter

Version: 3.1.2

OS: Windows 7 Ultimate SP1 - 64bit

Java Version: 7.0.50 - 64bit

Description of Problem:

Hi,

I wonder if anyone has noticed this issue, as it is quite a strange one.

1) We used 3.1.2 tekkit, which uses the most recent RP amongst a bunch of other stuff.

2) After a while, we noticed that timers were not animating correctly. In that the pointers were glitching and not rotating smoothly.

3) We removed the entire construction from the world down to every last pipe and mini block, however placing down a timer into this now blank world would result in a non smooth pointer animation.

4) We moved 1000+ blocks away and put down a timer, same issue. To areas that had not been visited before, same issue.

5) We MCEdit'ed the construction into a fresh world with the same seed. The timers were all smooth again.

6) We played for another week or so, and now the timers have started doing it again.

7) We have tried the server install on another hardware platform, same problem

8) Have tried clients on win7/osx, same problem

9) Re-starting the server does not fix the issue

10) The server was set to use 10gig ram and 64bit java

We had about 180 chests in our sorting facility, with about 36 redpower sorters. Pipes were colour coded on the back of all chests, and overflow from each chest would go either to the recycling plant or the overflow storage chests. I would estimate that there would be about 100 stacks of stuff rotating around the sorting system at all times.

Due to the time taken to exhibit this issue, it is quite hard to replicate, and the only temporary fix was to mcedit the construction into a new world.

Cheers.

Error Messages:

None

Error Log:

None

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Found the cause of this after some work. Problem with redpower it seems. When time (stored in the level.dat) file gets too big (whatever value that may be, who only knows) the timer animation stutters. Even with vanilla minecraft it does the same, so seems to be non tekkit related.

We have a work around by resetting the time to 1 for now using NBTedit. I do not really know if resetting time is going to mess a load of other stuff up, but it works for us at the mo.

Share this post


Link to post
Share on other sites
  • 0

i saw it so many episodes of Direwolf20's Let's Play on youtube, i thought it was just how it worked

now that i know its a bug, i'll scream at him in the comments

Share this post


Link to post
Share on other sites
  • 0

Thankfully, this doesn't get in the way of its function, so you can just bury it somewhere if you're desperate.

Also, things get really messed up if someone uses the Watch of Flowing Time

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this