Jump to content

IC2 Power not working


Recommended Posts


All over my server, no IC2 power is moving and I don't think its generating either. I connected a generator with coal in it to a batbox via some insulated copper cable. The batbox would not store any power, and using an eu-meter on the generator shows no power. I tried a similar thing with a solar panel in the daytime, also connected to a batbox, and the batbox would not charge.

I redownloaded the tekkit server, copied the world to the new server and tried the same, but with no luck. Is there something wrong with the world? And if so, is there anyway to fix it?

Thanks for reading!

Link to comment
Share on other sites

I assume you are probably trying to connect the wires to the side of the batbox with the orange dot. If so, that is the OUTPUT side, and inputs from generators need to go on a side that does NOT have an orange dot.

I can't think of anything else that would cause your problems.

Link to comment
Share on other sites

  • 2 weeks later...

I have a similar problem. I have had this problem at different points when trying to power machines though. I put up my server with electricity transmitting fine then after using solar electricity for awhile it just stopped powering all my furnaces. I replaced all the coppor cables that were running to my furnaces from my batbox that was being powered by the solar panels with insulated HV cables. It worked fine. Then It just randomly stopped working again. The Batbox was full but the furnaces would not take any power. I decided to just destroy it. I then made some water mills which did the same powered my Batbox to furnace system fine, then once again randomly the Batbox stopped emitting power and the furnaces stopped cooking. I replaced the HV cables that I had used this time with Glass-fibre cables and once again they worked fine. For a short period. I once again abolished the idea and went to just using batteries which worked fine. I eventually grew tired of this and wanted some more automation so I went to the nether and built an automated geothermal power system. The Geothermal generator went through a Batbox-MFU-LV Transformer - Multiple machines. All the machines worked for a short period then all of a sudden they stopped once again. When I replaced the cables this time nothing changed. I started to just go back to using Batteries or Lap-packs at this time. After awhile though that stopped working and I had to resort to RE-Batteries. After a VERY short time those stopped working aswell. I don't understand what is going on and can find absolutely nothing on the internet. Can anyone help?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...