Jump to content

Problem with installing tekkit 1.1 server not running


Recommended Posts

Hey guys I'm having a problem with installing tekkit.

I am using craftbukkit and MCmyadmin. Let me explain the situation

Since I cannot find a 1.1 server file of minecraft i'm using the latest snapshot before that. I can get the server to work on that snapshot without tekkit installed. As soon as I install tekkit (with the 1.1 snapshot on the server) the server won't boot anymore. it just says this

CONSOLE: ModLoader Server 1.1 Initializing...

CONSOLE: Mod Loaded: mod_BuildCraftBuilders 2.2.12

CONSOLE: Mod Loaded: mod_BuildCraftFactory 2.2.12

CONSOLE: Mod Loaded: mod_BuildCraftEnergy 2.2.12

CONSOLE: Mod Loaded: mod_BuildCraftCore 2.2.12

CONSOLE: Mod Loaded: mod_BuildCraftTransport 2.2.12

CONSOLE: Mod Loaded: mod_IC2 v1.71

CONSOLE: Mod Loaded: mod_RedPowerLighting 2.0pr4d

CONSOLE: Mod Loaded: mod_RedPowerArray 2.0pr4d

CONSOLE: Mod Loaded: mod_RedPowerMachine 2.0pr4d

CONSOLE: Mod Loaded: mod_RedPowerLogic 2.0pr4d

CONSOLE: Mod Loaded: mod_RedPowerWorld 2.0pr4d

CONSOLE: Mod Loaded: mod_RedPowerCore 2.0pr4d

CONSOLE: Mod Loaded: mod_RedPowerWiring 2.0pr4d

CONSOLE: Mod Loaded: mod_zAdditionalPipes Rev32.3

When I look further into McmyAdmin and look at About -> updates I see this:

Component Current version Latest version.

Minecraft Server Version [Not Running] 1.2.3

However, when I look in my FTP the minecraft snapshot file is still there. Does anyone have any idea what i'm doing wrong here?

Thanks

Link to comment
Share on other sites

Afraid that didn't work. Not sure what is meant with

copy your server into McMyAdmin/Minecraft

Like is that the minecraft_server.jar?

Also

Then rename your tekkit.jar to Craftbukkit.jar .

Does Craftbukkit.jar stay in the same folder or does that move to the McMyAdmin/Minecraft folder as well?

Either way it doesn't work. I still says

Minecraft Server Version [Not Running]

Link to comment
Share on other sites

Just noticed a weird thing, If I delete minecraft_server.jar and have the original craftbukkit.jar on the server, the server works fine, ! without a minecraft_server.jar! I am really confused now.

However, when i place tekkit.jar on the server an rename it to craftbukkit.jar It gives the message that minecraft_server.jar is not running, as you can read in my previous post. And even when I do place minecraft_server.jar on the server it still says the same thing.

Link to comment
Share on other sites

Not familiar with mcmyadmin, but unless it is drastically different from a standard server I am confused by your post. You say you are installing tekkit over a standard 1.1 server, none of which should be necessary. The Tekkit server DL is a standalone server that runs by itself. You just DL, extract, and run the launcher.

I am guessing this is simply my lack of knowledge of the system you are using, but just in case I thought I would throw in my impression on the off chance it helps :)

Link to comment
Share on other sites

Well you see, Mcmyadmin runs craftbukkit by default if it's in the FTP. I read some solutions and one of them is to rename tekkit.jar to craftbukkit.jar. But this didn't work for me. I cannot place the launcher.bat in my FTP because the host does not allow it to be replaced. But thank you for your response DragnHntr :)

Link to comment
Share on other sites

Well you see, Mcmyadmin runs craftbukkit by default if it's in the FTP. I read some solutions and one of them is to rename tekkit.jar to craftbukkit.jar. But this didn't work for me. I cannot place the launcher.bat in my FTP because the host does not allow it to be replaced. But thank you for your response DragnHntr :)

Gotcha, so since MCmyadmin is designed to run craftbukkit, you need to trick it into thinking tekkit is bukkit, which should work because, well it is bukkit lol.

I still can't help but think you are over-working it. I have only ever hosted servers on my own machine so i'm not sure what you can and can't do, but if it was my machine and I was trying to do this, I would remove everything (or just create a new folder to run it from), install ONLY tekkit, and then rename the tekkit jar to craftbukkit.jar and see if it runs. Best of luck :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...