Jump to content

Connect to Tekkit Server - :( doesn't work.


Recommended Posts

I am really struggling to connect to a Tekkit Server. I have been trying for weeks but it just will not work. I have tried using dev build options, manually selecting builds, most say to use 3.0.3|1.2.5 but i always get the message saying that mods are needed and a list of the mods. They couldn't have made it that difficult to connect to a server could they?

what can I do next?


Link to comment
Share on other sites

What mods do you need? If it gives you a list, you have the wrong version.

Tried many servers and configurations, it is different all the time. Some need more, some don't.

I may be being complete dube here but when I load Tekkit you get a drop down graphic box on the left hand side. You've got TEKKIT, then TEKKIT with a black background, Yogbox and someother, cant remember now.

I have tried DEV builds, different build types but still to no avail.

Here is an example


I was trying to join this server.. It says that it is a 3.1.2 server but it doesn't say what client or build you should use. So really I am at a loss with Tekkit at the moment. I even downloaded and ran the latest server then connected to it locally using the latest build in the client but still said out of date or needed mods.

Any more ideas?


Link to comment
Share on other sites

You use the Technic client (the client is the launcher). 3.1.2 is the build you use. When you first open the launcher (BEFORE you log in) choose options, then you can either select 3.1.2 manually or recommended build (3.1.2 is the current recommended build). If for some reason there is a new recommended build, and the server you play on has not updated (which is common because they have to wait on the protection plugins to also update) then select the build manually and go back to 3.1.2. Dev builds are meant for people who want to be testers and work out bugs, not the average player.

Link to comment
Share on other sites

  • 1 month later...

Hello I'm pretty new to Tekkit, when I also tried to create my own server to play lan with a friend, I get the out of date message too.

When I try to switch through the versions I don't see no 3.1.2, All I see is 7.5.1. What's with that? :)


You're running Technic, which doesn't work on a Tekkit server. It's a Single Player Only modpack.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...