Jump to content
  • 0

Attack of the B-Team fails to start world


Haroldean
 Share

Question

Hello-

I've built an insane world on AOTB but a few months ago it wouldn't let me start my save (The modpack launched fine, but says "Shutting down internal server" after a few seconds)

I thought the problem had to due with villager.dat files and i removed them, but the issue still stands.

Crash report: 

 

-- Head --
Stacktrace:
    at net.minecraftforge.common.Configuration.load(Configuration.java:625)
    at net.minecraftforge.common.Configuration.<init>(Configuration.java:100)
    at net.minecraftforge.common.Configuration.<init>(Configuration.java:106)
    at mapwriter.forge.MwConfig.<init>(MwConfig.java:12)
    at mapwriter.Mw.loadWorldConfig(Mw.java:238)
    at mapwriter.Mw.onClientLoggedIn(Mw.java:475)
    at mapwriter.forge.MwConnectionHandler.clientLoggedIn(MwConnectionHandler.java:52)
    at cpw.mods.fml.common.network.NetworkRegistry.clientLoggedIn(NetworkRegistry.java:211)
    at cpw.mods.fml.common.network.FMLNetworkHandler.onConnectionEstablishedToServer(FMLNetworkHandler.java:91)
    at net.minecraft.client.multiplayer.NetClientHandler.func_72455_a(NetClientHandler.java:357)
    at net.minecraft.network.packet.Packet1Login.func_73279_a(Packet1Login.java:119)
    at net.minecraft.network.MemoryConnection.func_74428_b(MemoryConnection.java:89)

 

I read thru these forums that modpacks can appear on these reports which confirms that that specific pack is the issue, but not sure about where the issue originates in this report

Hope one of y'all gets back to me to make this quarantine less boring ❤️

Edited by Haroldean
bad coloring
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Mapwriter config got borked. Its either the main config file or the waypoints for your minimap.

The borked file can be deleted just fine, although in case of the waypoints, you'll lose all the waypoints on your minimap.

The location of the file you need to delete can be found in the error juuuuust above what you pasted here.

Link to comment
Share on other sites

  • 0

Awesome! Worked once but now the save wont pop up when i launch AOTB - Tried a new world with the same name as the file but the game just crashes now...

Time: 4/26/20 10:33 PM
Description: Loading entity NBT

java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.ArrayList.rangeCheck(Unknown Source)
    at java.util.ArrayList.get(Unknown Source)
    at net.minecraft.nbt.NBTTagList.func_74743_b(NBTTagList.java:113)
    at net.minecraft.entity.Entity.func_70020_e(Entity.java:1619)
    at net.minecraft.world.storage.SaveHandler.func_75752_b(SaveHandler.java:296)
    at net.minecraft.server.management.ServerConfigurationManager.func_72380_a(ServerConfigurationManager.java:245)
    at net.minecraft.server.management.ServerConfigurationManager.func_72355_a(ServerConfigurationManager.java:113)
    at net.minecraft.server.integrated.IntegratedServerListenThread.func_71747_b(IntegratedServerListenThread.java:97)
    at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:691)
    at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:587)
    at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:129)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:484)
    at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:583)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
    at java.util.ArrayList.rangeCheck(Unknown Source)
    at java.util.ArrayList.get(Unknown Source)
    at net.minecraft.nbt.NBTTagList.func_74743_b(NBTTagList.java:113)

 

lmk if you can help out! I've got all the original world files copied and saved as well
 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...