Jump to content

Technic launcher refuses to download custom modpack


Recommended Posts


Me and my friends have been running a custom modpack on our server.

If I launch the modpack locally, it works just fine and I can get into the server. I attempted to update the custom modpack version for my friends. Zipped up the bin and mods files, uploaded them to Dropbox, and attempted to update the modpack.

When I did, I got this error in the console:
[B#771] java.lang.NullPointerException
[B#771]     at net.technicpack.minecraftcore.install.tasks.HandleVersionFileTask.runTask(HandleVersionFileTask.java:116)
[B#771]     at net.technicpack.launchercore.install.tasks.TaskGroup.runTask(TaskGroup.java:85)
[B#771]     at net.technicpack.launchercore.install.InstallTasksQueue.runAllTasks(InstallTasksQueue.java:49)
[B#771]     at net.technicpack.launchercore.install.ModpackInstaller.installPack(ModpackInstaller.java:42)
[B#771]     at net.technicpack.launcher.launch.Installer$1.run(Installer.java:123)
[B#771]     at java.lang.Thread.run(Unknown Source)

It won't let me install the modpack at all. It gets about 50% of the way done, then it stops and outputs this error to console. Tried deleting my local files, tried clicking reinstall pack, neither of those worked.

Error log is uploaded below.
Help would be much appreciated.


Here's the pastebin version of the log I uploaded:

Link to comment
Share on other sites

6 hours ago, JaariAtmc said:

Did you extract modpack.jar, and then added .jar, because I see both files I shouldn't be seeing, and a modpack.jar.jar.

I tried renaming it and double-checking everything. That shouldn't be the case though, I have no idea why it would say there was a second modpack.jar. I'll upload a screenshot of exactly what I'm trying to upload vs. what's actually in my bin folder. Also, the console started throwing up this error. I think it's new, but I'm not 100% sure.

[B#771] File install_profile.json not found in D:\Technic Launcher\modpacks\vans-kobd-modpack\bin\modpack.jar

Regarding the image below, the left is what I'm trying to download, the right is what actually downloads.


Link to comment
Share on other sites

  • Forum Administrators

Forge update 1.12.2- changed things. You need the Forge Installer renamed as modpack.jar instead of Universal. Download and rename the Installer, DO NOT run/install/extract the installer.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...