Jump to content

Missing Mods


Recommended Posts

Okay, so sorry if the answer is anywhere else, did some searching for about 2 hours and had enough of it, so I'll ask here.

I wanted to host a small Tekkit server for my friends and I and when I tried to connect it says that I'm missing the following mods:





(they are all listed in the mods thingy at the menu as loaded)

Now I've seen people say that you have to have the same version of the launcher as you do the server, which I have tried and it still did not work. Next I tried again after deleting the ENTIRE Techic Launcher folder (except my tekkit saves) and it still would not connect.

I'm using a Mac (I hate 'em but it's a school laptop) and I've been using Port Map to forward my ports. I've been hosting a normal 1.4.6 MC server for my friends and I so I'm sure it can't be a system problem. I have also tried deleting and renaming the NetherOres mod, not sure if it relates but figured I should say something at least.

Thanks in advance for any help!

Link to comment
Share on other sites

Your clients and server run different Tekkit versions. 3.1.3 uses later mod versions than 3.1.2, so the two are not compatible. Unless you have changed something in your launcher, your clients are at 3.1.2, so you should probably go grab the 3.1.2 server, delete your existing mods folder in the server you have, and put the 3.1.2 files in. If you are willing to accept some broken features to use newer mod versions, set your client to tekkit 3.1.3 in the options menu.

Link to comment
Share on other sites

I was running the 3.1.2 client and server before I posted this. In any event, I deleted everything related to Tekkit and redownloaded the 3.1.2 server and launcher. Still no luck. Tried what you said above about switching the mods folder, still didn't work.

Any ideas why this is happening?

Link to comment
Share on other sites

  • 3 weeks later...

Now, the only available download from technicpack.net is for 3.1.2. I have had the same problem; here's how to solve it:

1. Open Technic Launcher and choose Tekkit Classic.

2. Click on the "Options" button below the "Login" button.

3. There will be a couple of options that say, "Always use developmental builds." and "Always use recommended builds." Choose "Always use developmental builds." And log in. There may be a window that says there is an update available for Tekkit and it will ask if you want to download it. Click "Yes."

If this window doesn't show up, it still might work.

Hope this helped!

Link to comment
Share on other sites

He's saying that, even though you say the server/client is correct, you should double-check it because the change in the mods suggest otherwise. Try redownloading the server, maybe? I really don't know why it would say what it is if the versions are correct.

edit: ninja'd

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...