• 0
Sign in to follow this  
Ozuma36

Tekkit Lite crashes before it starts!

Question

Title: Tekkit Lite crashes before it starts!

Version: 0.5.2

OS: Mac OS X 10.8.2

Java Version: 1.7.0 latest for Mac OS X

Description of Problem:

After deleting and reinstalling the Technic launcher like the massive banner at the top of the site says, I still can't launch anything. Technic and all other mods besides Lite will launch and stick at a white screen. Tekkit Lite simply won't launch.

Error Messages:

Before Tekkit Lite even launches, the Technic Launcher opens a window that says: "Minecraft failed to start, errors reported in the log."

Error Log:

[12:33:39] [sEVERE] ------------------------------------------

[12:33:39] [sEVERE] Launcher is starting....

[12:33:39] [sEVERE] Launcher Build: '1.1.1.0'

[12:33:39] [sEVERE] Allocated 910.25 Mb of RAM

[12:33:39] [sEVERE] Java VM: '1.7.0_04-ea-b17'

[12:33:39] [sEVERE] OS Version: '10.8.2'

[12:33:39] [sEVERE] Is 64-bit: 'true'

 

--cut some stuff out--

 

[12:34:29] [sEVERE] Downloading 'none'

[12:34:29] [sEVERE] java.net.MalformedURLException: no protocol: none

[12:34:29] [sEVERE] at java.net.URL.<init>(URL.java:583)

[12:34:29] [sEVERE] at java.net.URL.<init>(URL.java:480)

[12:34:29] [sEVERE] at java.net.URL.<init>(URL.java:429)

[12:34:29] [sEVERE] at org.spoutcraft.launcher.async.Download.<init>(Download.java:49)

[12:34:29] [sEVERE] at org.spoutcraft.launcher.DownloadUtils.downloadFile(DownloadUtils.java:35)

[12:34:29] [sEVERE] at org.spoutcraft.launcher.modpacks.ModPackUpdater.extractCustomZip(ModPackUpdater.java:99)

[12:34:29] [sEVERE] at org.spoutcraft.launcher.modpacks.ModPackUpdater.updateModPackMods(ModPackUpdater.java:86)

[12:34:29] [sEVERE] at org.spoutcraft.launcher.gui.LoginForm$3.doInBackground(LoginForm.java:831)

[12:34:29] [sEVERE] at org.spoutcraft.launcher.gui.LoginForm$3.doInBackground(LoginForm.java:807)

[12:34:29] [sEVERE] at javax.swing.SwingWorker$1.call(SwingWorker.java:296)

[12:34:29] [sEVERE] at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)

[12:34:29] [sEVERE] at java.util.concurrent.FutureTask.run(FutureTask.java:166)

[12:34:29] [sEVERE] at javax.swing.SwingWorker.run(SwingWorker.java:335)

[12:34:29] [sEVERE] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)

[12:34:29] [sEVERE] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)

[12:34:29] [sEVERE] at java.lang.Thread.run(Thread.java:722)

[12:34:31] [sEVERE] Loading Launcher from 'techniclauncher/tekkitlite'

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

Ugh... whut? Oh. Mac. Riiiight, here we go, may need to wait for backup.

And did you not think that one might need the stuff you cut out?

I myself wanna see the whole thing instead of wildly theorising. Put it into pastebin.com

Share this post


Link to post
Share on other sites
  • 0

Ugh... whut? Oh. Mac. Riiiight, here we go, may need to wait for backup.

And did you not think that one might need the stuff you cut out?

I myself wanna see the whole thing instead of wildly theorising. Put it into pastebin.com

Sorry about not including everything. The rest just seemed ordinary. Here is the full version of the log:

http://pastebin.com/wFgs4iAc

I also get a different error log if everything is downloaded already:

http://pastebin.com/UME7v212

Share this post


Link to post
Share on other sites
  • 0

MalformedURL? Sounds like a firewall/AV program is blocking the download. Try disabling them and downloading.

Share this post


Link to post
Share on other sites
  • 0

MalformedURL? Sounds like a firewall/AV program is blocking the download. Try disabling them and downloading.

Well, first of all, this is Mac. There are no AV programs. Second of all, yeah Mac has a really tight firewall that might be interfereing. One problem. You can't unblock JAR's, only .app's. Until Technic is remade into an app, you can't pass it through the firewall.

Also, I don't think thats the problem anyway, I think the problem is that "none" isn't a URL. I'll see about the firewall and what I can do about it.

EDIT: Tested with firewall off. Didn't change anything.

Share this post


Link to post
Share on other sites
  • 0

See my last post.

My apologies, but this error is

a) something I haven't seen in Minecraft

B) something I have seen elsewhere.

It's trying to call up a URL it can't find. It's gotta be your firewall.

Share this post


Link to post
Share on other sites
  • 0

My apologies, but this error is

a) something I haven't seen in Minecraft

B) something I have seen elsewhere.

It's trying to call up a URL it can't find. It's gotta be your firewall.

Well, I tested it with the firewall off, so it can't be that. Also, no need to apologize, you are being really helpful and awesome!

I do think that it is because its trying to access a URL called "none". That doesn't sound like a URL to me.

Anyway, if you know how they made the old version of the Technic Launcher into an application, that would probably fix my problems.

Share this post


Link to post
Share on other sites
  • 0

Nerp, I'm outta here.

Tag!

I'm pretty sure it has to do with the new custom zip URL's. I don't have anything in there, so maybe it's trying to access a URL called "none". Can malformedURL mean that the URL doesn't exist?

Share this post


Link to post
Share on other sites
  • 0

I'm seeing a similar error with TechnicLauncher on win7. I've disabled my Norton Security Suite's firewall and virus checking:

[21:20:08] [sEVERE]    ------------------------------------------

[21:20:08] [sEVERE]    Launcher is starting....

[21:20:08] [sEVERE]    Launcher Build: '1.1.2.0'

[21:20:08] [sEVERE]    Allocated 910.25 Mb of RAM

[21:20:08] [sEVERE]    Java VM: '1.7.0_11-b21'

[21:20:08] [sEVERE]    OS Version: '6.1'

[21:20:08] [sEVERE]    Is 64-bit: 'true'

[21:20:08] [sEVERE]    [info] Downloading 'mirrors.yml' from 'http://mirror.technicpack.net/Technic/mirrors.yml'.

[21:20:09] [sEVERE]    Downloading 'http://206.217.207.1/Technic/CHECKSUM.md5'

[21:20:09] [sEVERE]    Downloaded 'launcherCHECKSUM.md5'

[21:20:10] [sEVERE]    [info] Downloading 'modpacks.yml' from 'http://206.217.207.1/Technic/modpacks.yml'.

[21:20:19] [sEVERE]    Downloading 'http://mirror.technicpack.net/Technic/technicssp/resources/icon.png'

[21:20:19] [sEVERE]    Downloading 'http://206.217.207.1/Technic/hackslashmine/resources/icon.png'

[...]

[21:21:52] [sEVERE]    Downloading 'http://206.217.207.1/Technic/mods/z-technic-configs/z-technic-configs-v7.2.6.zip'

[21:21:52] [sEVERE]    Downloaded 'tempz-technic-configs-v7.2.6.zip'

[21:21:52] [sEVERE]    Extracting tempz-technic-configs-v7.2.6.zip to technicssp

[21:21:54] [sEVERE]    Extracted tempz-technic-configs-v7.2.6.zip to technicssp

[21:21:54] [sEVERE]    Downloading 'none'

[21:21:54] [sEVERE]    java.net.MalformedURLException: no protocol: none

[21:21:54] [sEVERE]        at java.net.URL.<init>(Unknown Source)

[21:21:54] [sEVERE]        at java.net.URL.<init>(Unknown Source)

[21:21:54] [sEVERE]        at java.net.URL.<init>(Unknown Source)

[21:21:54] [sEVERE]        at org.spoutcraft.launcher.async.Download.<init>(Download.java:49)

[21:21:54] [sEVERE]        at org.spoutcraft.launcher.DownloadUtils.downloadFile(DownloadUtils.java:35)

[21:21:54] [sEVERE]        at org.spoutcraft.launcher.modpacks.ModPackUpdater.extractCustomZip(ModPackUpdater.java:99)

[21:21:54] [sEVERE]        at org.spoutcraft.launcher.modpacks.ModPackUpdater.updateModPackMods(ModPackUpdater.java:86)

[21:21:54] [sEVERE]        at org.spoutcraft.launcher.gui.LoginForm$3.doInBackground(LoginForm.java:832)

[21:21:54] [sEVERE]        at org.spoutcraft.launcher.gui.LoginForm$3.doInBackground(LoginForm.java:808)

[21:21:54] [sEVERE]        at javax.swing.SwingWorker$1.call(Unknown Source)

[21:21:54] [sEVERE]        at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)

[21:21:54] [sEVERE]        at java.util.concurrent.FutureTask.run(Unknown Source)

[21:21:54] [sEVERE]        at javax.swing.SwingWorker.run(Unknown Source)

[21:21:54] [sEVERE]        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

[21:21:54] [sEVERE]        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

[21:21:54] [sEVERE]        at java.lang.Thread.run(Unknown Source)

[21:21:54] [sEVERE]    Loading Launcher from 'techniclauncher/technicssp'

[21:21:55] [sEVERE]    IDResolver - Loaded 785 IDs sucessfully.

[21:21:55] [sEVERE]    IDResolver - Loaded 39 Mod Priorities sucessfully.

[21:21:55] [sEVERE]    IDResolver - 'UpdateTickSettings' called.

[21:22:00] [sEVERE]    Attempting early MinecraftForge initialization

[21:22:00] [sEVERE]    Completed early MinecraftForge initialization

[21:22:00] [sEVERE]    2013-01-25 21:22:00 [iNFO] Forge Mod Loader version 2.2.106.176 for Minecraft c:1.2.5, s:1.2.5 loading

[...]

Share this post


Link to post
Share on other sites
  • 0

I have the same problem but i have a windows 7 premium and a windows 8 premium. and its not because my firewall is blocking it. I tested to see if MinecraftForge works on regular Minecraft and it did so its definitely because theres someting wrong with with the launcher. Please, Help me

Share this post


Link to post
Share on other sites
  • 0

I have the same problem but i have a windows 7 premium and a windows 8 premium. and its not because my firewall is blocking it. I tested to see if MinecraftForge works on regular Minecraft and it did so its definitely because theres someting wrong with with the launcher. Please, Help me

whoops, i forgot. MinecraftForge in Windows 8 is a failure.

Share this post


Link to post
Share on other sites
  • 0

I have a couple of comments - I am having the same issue and although I haven't yet solved it I had a breakthrough in understanding the problem. Firstly - it's safe to ignore the java exception, its arises due to a null value in the custom zip property but I am sure that launcher handles this and just ignores the custom zip as you didn't specify one - as you will see the line immediately following this is:

Loading Launcher from 'techniclauncher/technicssp

So I am pretty sure it's 'something else' - BTW I have also tried: http://www.minecraftwiki.net/wiki/Tutorials/Update_LWJGL just in case but no dice. I'll keep you posted if I find anything. I think it's one of these pesky java updates... had quite a few issues on other java apps too.

Share this post


Link to post
Share on other sites
  • 0

I have it working now - here is what i did. As far as I can see technic Launcher and Java 7 dont play too well. Perhaps you can get it to work but I used this work around. NOTE that this is not supported by apple or me for that matter use at your own risk etc..

Assumes: You are running OSX 10.8 Java 7 latest and need to have Java 6 available for in this case technic_launcher

1. (re) Install Java 6 - you can get this from here: http://apple-java-for-mac.en.softonic.com/mac/download - it's a dmg/pkg and follow the prompts - it will install the final Java6 release

2. Create a launch.sh script with something like :

export JAVA_HOME=$(/usr/libexec/java_home -v 1.6)

cd /where your technic-launcher is/

java -jar technic-launcher.jar

3. Download the latest technic_launcher.jar for OSX - really do this evebn if you think you have done it before.

4. As a last resort - clear the cache / delete ~/Library/Application\ Support/techniclauncher

Your latest Java 7 should be unaffected although I am still checking it over so as I said use at your own peril.

NOTE WELL: Java 6 is obsoleted and will be vulnerable - be aware of this and take appropriate precautions to prevent any unwanted results. You know the score.

I hope this helps you and anyone else in bother.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this