Jump to content

Strange behaviour when picking up tools


Recommended Posts


I set up my Tekkit Lite server yesterday and noticed something strange:

When I drop a tool (By pressing the Q-Button), it will immediately pop up in my shoe-slot, making my shoes disappear forever. The dropping itself is very strange too. It is not like in Vanilla Minecraft, when you drop it on the floor and when you can pick it up a second or two later. When I press "Q" in Tekkit Lite, it does not even take a tenth of a second until the tool appears in my shoe slot again - it happens that fast, I do not even see it dropping. It is just gone from my item bar and immediately appears in the slot, my shoe is meant to be in. If I drop another tool now, it will overwrite the tool I dropped before - like it does with my shoes.

Everyone on the server experiences this problem. But appearently, this is only affecting the tools - any other item can be dropped and picked up again perfectly normal.

I have allready tried those things to solve this:

- We were playing on 0.5.2 first, so I updated to 0.5.3 - but it did not change anything.

- I restarted the server a few times but that did not help, too.

- I deleted everything except for the world (The old parts of the world are generated by Vanilla Minecraft 1.4.2 - I simply copied it to my Tekkit Lite server. Is that maybe the problem?) and reinstalled Tekkit Lite.

My friends and me also tried this in singleplayer. There it worked fine for everyone.

Does anyone else experience these kind of problems, too? Or does anyone even know how to fix this? I lost 4 pairs of diamond shoes before I finally figured out, what happened to them.

Thank you!

Greetings from Germany!

Link to comment
Share on other sites


I figured out now, how to solve the problem:

A new player played on the server and for him, everything worked fine. So I considered the old Vanilla-player-files causing the problem. So I put all my things into a chest and deleted my player-file. After restarting the server and rejoining, everything works fine now.

It could be that InvTweaks was not able to read this file-format or something like that. So maybe you are right, too.

But anyways: thank you for your advice!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...