Jump to content

Problem with superflat and copper ore

Recommended Posts

I am having a major problem with creating a superflat world. I tried to create a superflat world with layers of all the ores from within the tekkit lite pack. I did a bit of searching to find which of the copper ores was being used (as the various mods seem to have different copper ores but NEI only shows one). After pinning down which IDs to use I created my world.

It was extremely laggy and at some point simply stopped generating new chunks. I dug down to try to see if all the layers had generated properly. When I hit the copper ore layer (after a layers of iron, coal, sand, and gravel) I didn't find copper ore. Instead I found some sort of weird machine I couldn't destroy, even in creative.

I went back tried to generate a world with just one layer of bedrock, one layer of copper ore and one layer of grass. It wasn't nearly as laggy but the copper ore had once again been replaced by the same machines. Thinking that this might be an ID conflict, I then tried to change the ID of the copper ore block (I had found it in Thermal Expansion at ID 2001). After trying several times to change the ID and failing (it either gave me a ID conflict error or just froze), I finally found that 2200 worked, well it created a new world anyways. When I dug down to the copper again, instead of copper I found Automated Crafting Tables. Completely different IDs. I have no idea what is happening at this point.

At the time i first encountered this error I had added railcraft separately, but have since reloaded a Tekkit Lite fresh and produced the same results. Anybody know of a solution for this? Anybody know which mod might be responsible? Who do I submit the bug report to?

Link to comment
Share on other sites

Interesting. My NEI lists 4. Although ones of those is nether copper ore but I seem to have a 5th copper ore that is hidden from nei. I have shuffled some IDs around, but right now I have copper ores(excluding nether copper ore) at block IDs:254, 3790, 2001, 1398.

Spawn a forge lexicon and a copper ore. Open the lexicon by shift right clicking and put the copper ore in it, you can flip through every other copper ore registered in forge and shift it to any of them.

Link to comment
Share on other sites

The forge lexicon only shows me 2, Thermal Expansion at 2200 (was 2001) and one at 254:5, 254 appears as Ruby Ore, 254:5 doesn't show up in NEI.

Edit: 254:5 works fine for copper, It appears the RP Ores are there but have been concentrated into 254:x and don't show up in NEI. None of the other mods' copper appear but that's ok, RP copper generates just fine as do the other ores.

Edt: I just tried to remake my first world (with every ore available) using the 254s instead of the 2200s, the 254s worked like a charm but The unique ores (lead and ferrous) I had to use the 2200's, and they didn't come out at all. Huh they just don't like being generated in a superflat. Oh well, no big loss.

Link to comment
Share on other sites

  • 2 months later...

i suggest making a superflat using the overworld preset, thats what me and a friend have done and we are finding everything, but youll need to add in trees...

believe me it saves alot of that screwing around

edit: sorry to necromance this but it seems that the problem wasnt 100% solved

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...