Jump to content

Wrong Location Error


Recommended Posts

I play on a tekkit lite server with a few friends, and I run the server myself from the same computer I play on. I usually have no problems, but recently the server has had some serious issues. It spits out the same error message over and over so quickly that I can't even read it live. It seems a highly glitchy pig is the culprit:

[iNFO] [sTDOUT] Wrong location! pd['Pig'/1189, l='world', x=-867.14, y=64.00, z=-1418.98]

[iNFO] [sTDERR] java.lang.Exception: Stack trace

[iNFO] [sTDERR]    at java.lang.Thread.dumpStack(Unknown Source)

[iNFO] [sTDERR]    at zz.a(Chunk.java:923)

[iNFO] [sTDERR]    at aam.a(AnvilChunkLoader.java:406)

[iNFO] [sTDERR]    at aam.a(AnvilChunkLoader.java:103)

[iNFO] [sTDERR]    at aam.a(AnvilChunkLoader.java:83)

[iNFO] [sTDERR]    at im.f(ChunkProviderServer.java:182)

[iNFO] [sTDERR]    at im.c(ChunkProviderServer.java:118)

[iNFO] [sTDERR]    at il.<init>(PlayerInstance.java:43)

[iNFO] [sTDERR]    at ik.a(SourceFile:172)

[iNFO] [sTDERR]    at ik.a(SourceFile:203)

[iNFO] [sTDERR]    at gm.a(ServerConfigurationManager.java:163)

[iNFO] [sTDERR]    at gm.c(ServerConfigurationManager.java:206)

[iNFO] [sTDERR]    at gm.a(ServerConfigurationManager.java:123)

[iNFO] [sTDERR]    at it.completeConnection(NetLoginHandler.java:198)

[iNFO] [sTDERR]    at cpw.mods.fml.common.network.FMLNetworkHandler.handleClientConnection(FMLNetworkHandler.java:153)

[iNFO] [sTDERR]    at cpw.mods.fml.common.network.FMLNetworkHandler.onConnectionReceivedFromClient(FMLNetworkHandler.java:107)

[iNFO] [sTDERR]    at it.d(NetLoginHandler.java:182)

[iNFO] [sTDERR]    at it.c(NetLoginHandler.java:75)

[iNFO] [sTDERR]    at hu.a(ServerListenThread.java:56)

[iNFO] [sTDERR]    at ht.b(SourceFile:29)

[iNFO] [sTDERR]    at net.minecraft.server.MinecraftServer.r(MinecraftServer.java:703)

[iNFO] [sTDERR]    at ho.r(DedicatedServer.java:269)

[iNFO] [sTDERR]    at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:599)

[iNFO] [sTDERR]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:497)

[iNFO] [sTDERR]    at fy.run(SourceFile:849)

Tekkit Lite Version: 0.6.1

Java Version: 7, update 21

Each time it's the same location, always a pig. The number following the pig increases every time, by one (1189 to 1190 and so on). Opening the level in worldedit shows a strange entity at the location, possibly a stack of many entities. It cannot be deleted. Approaching the pig in-game causes immense lag and eventually drops all clients.

I tried reinstalling everything, and I isolated the problem to the /world/region folder. The problem goes away when I regenerate a region folder, at the expense of everything that we've created. The server does not spit out errors until a player approaches the pig and the chunk is loaded. For this reason I can't get close enough in-game. I've also noticed that the chunk containing it is a different biome than the surrounding area...

I've been using tekkit for a while now, but I don't really know what I'm doing. I need some help getting rid of this error... I'm willing to destroy the area it's in but I don't want to lose everything else in my map :(

Please Help.

Link to comment
Share on other sites

I run a server on my PC and play on it as well, and a few times now the power has gone out or my client has crashed hard enough for me to have to hard reboot my computer without properly closing the server and some chunks will get corrupted. This message is how I usually find out, and every time I've been able to fix it by just deleting the offending chunk, so try that. MCEdit will do the job. Hopefully there's nothing important in that chunk, but at least this is a good reminder to do server backups more often.

Link to comment
Share on other sites

Thanks for the Reply!

Unfortunately, Worldedit allows for the deletion of the chunk but the bugged entity doesn't go with it...


The red box in the middle is the pig, or likely stack of infinite pigs. As you can see, the chunk is deleted. Upon world re-entry, the problem persists. It should also be noted that Worldedit lags massively when the render window gets too close to it. Using the delete entities tool does not provide results, and the analyze blocks tool does not give data on the pig(s).

Solution (sorta): I managed to find the file responsible for the group of chunks in /world/region that contained the error, and deleted it. This solved the problem. To prevent a giant world crease in the area and to preserve some of the structures we built, I used Worldedit to copy a large area and drop it into the butchered world file. This resulted in a plethora of new errors, and Worldedit seems to have lots of trouble copying tekkit ores/machines/everything. BUT it fixed the error.

I'm still looking into other solutions, The one above isn't acceptable. Any assistance would be greatly appreciated. I've definitely learned to create backups more often, I just hope I can salvage our base and surrounding area.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...