Jump to content

Need Java 6 for Mac


Recommended Posts


I'm sorry for posting this here as I'm pretty sure this is the completely wrong area of the forum for such a thread, but after having had a look around the forum and not seeing where I should and could post it, I was forced to post it here.

I'm basically wondering if anyone would be able to link me to a download of Java 6 for Mac.

I used to play Tekkit about half a year or more ago, though it suddently stopped working. At the time, I tried multiple times to fix the problem but ended up going around in circles and getting nowhere.

As a last attempt to sort the problem out and save myself from having to buy another computer to play tekkit and other games on, I've been working on it for the last 5 hours. I deleted all files relating to tekkit, technic and java off my mac into the bin, which i then emptied, thus permanently deleting them. I then downloaded the tekkit launcher for mac off the main tekkit page, but have found that I need Java 6 to use it.

Please, if anyone can help me out, I would very much appreciate it.


Link to comment
Share on other sites

What version of OS X are you running? Also, you probably already have Java 6 installed, open /Applications/Utilities/Terminal.app and type:

java -version

For some reason the TechnicLaumcher.jar is falsely identifying the Java 7 WEB plugin as the version of the Java RUNTIME. They are not the same, and I've noticed that same error myself on at least 4 different Macs. Persistence is the key, quit the launcher and run it again. Eventually it will stop pestering you and work fine, has for me.

Link to comment
Share on other sites

I stopped there for a the night, might try and sort it again later.

I'm running OS X version 10.7.5

I typed in what you said and here is the full text from terminal


Andrews-iMac:~ Andrew$ java -version

java version "1.7.0_21"

Java SE Runtime Environment (build 1.7.0_21-b12)

Java HotSpot 64-Bit Server VM (build 23.21-b01, mixed mode)

Andrews-iMac:~ Andrew$


Any suggestions on what to do now?

Link to comment
Share on other sites

Yeesh, it looks like you did upgrade your Java runtime to Java 7. FYI, the java runtime offered by Apple is only version 6, so at some point it looks like you must have manually upgraded to the 7 runtime. I'll look into it, there should be a way to go back without erasing the system and reinstalling.

Link to comment
Share on other sites

It occurs to me that your path might be invoking the Java 7 web plugin path as opposed to the JRE in /usr/bin. Try running this command in Terminal to confirm if Java 7 JRE is actually installed as the system default:

/usr/bin/java -version

Also, run this:

which java

That will tell you the path your system is using.

Link to comment
Share on other sites

One other Terminal command:

ls -la /usr/bin/java

This will tell us if the symlink is pointing at the right VM. On a working system, it should point to

/usr/bin/java -> /System/Library/Frameworks/JavaVM.framework/Versions/Current/Commands/java

. I suspect on your system it is pointing to Internet Plug-Ins, which should be an easy enough fix if so.

Link to comment
Share on other sites

My school gave us Macs for our school laptop, I have to play Technic by running java -jar technicpack.jar

Its funny, because for Testing they need us to have Java 7 so it will run. Which apparently I have Java 6 and 7 installed, and when I run programs by clicking it runs it with Java 7, but when I do "java -jar technicpack.jar" in Terminal, it works fine. Its like Terminal is used Java 6 and everything else is using Java 7 xD.

Link to comment
Share on other sites

Your school probably configured the default application to open .jar files as the plugin in /Library/Internet Plug-Ins instead of the system Java VM. You can change this for JUST the TechnicLauncher.jar file by right clicking (or control clicking) on the file in a Finder window, selecting "Get Info", and changing the "Open With" selection to "Jar Launcher 14.7.0". Then you won't have to open it via Terminal, you can just double click it.

If you don't see Jar Launcher 14.7.0 from the pulldown, you can select "Other" and then manually browse to:

/System/Library/CoreServices/Jar Launcher
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...