Jump to content

Normal fps yet unplayable lag?


Recommended Posts

Hello there,

Since a server I was playing on turned tekkit lite, I haven't played yet, since it's unplayable for me.

The lag was horrible and when I looked to my framerates, it dropped from the usual 30-40 to 5-10. After finally getting Optifine to work, my fps became normal, even higher than usual, which is good of course.

The problem is that, even though it's running at 40 fps, it lags so much that it's unplayable. It's not internet lag, it's lag from the game since when I'm moving my mouse for example, it takes literally seconds to move, with a lot of stutter.

Some (maybe useful) extra information:

- OS: Max OS X 10.8

- RAM: 4GB (of which 3GB assigned to technic in the technic launcher)

Server seems to be playable for other players, minecraft version 1.4.7.

Thanks in advance,

Nich

Link to comment
Share on other sites

One possibility is you are not leaving enough ram for the os/background processes, thus causing tons of hard faults. Decrease the ram allocation and see if that helps.

Does this only happen in certain locations of your map?

You could also try disabling smooth lighting.

Link to comment
Share on other sites

1. I tried reinstalling again by removing the old java and installing a new one.

2. Here is a picture of the debug screen, I hope it's useful. The world is a relatively new multiplayer world and seems to work fine for others. My cpu is a 2.66Ghz intel core 2 Duo and my gpu is a Nvidia gt 9400 (iMac 2009)Schermafbeelding%202013-05-30%20om%2017.

Link to comment
Share on other sites

Your graphics card is on the low end. You could try updating it + LWJGL as suggested, though that might not fix the problem.

If it's only certain sections of the world that lag, then it might be machinery. Some things make the renderer slow.

Don't play on full screen. It could be hindering your performance.

Link to comment
Share on other sites

I had a very similar issue on our family's Mac Mini running OS 10.8. Oddly enough going to video settings and turning full screen mode to "on" fixed the problem. It seems like an optimization issue of some kind.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...