Jump to content

Voltz - Strange TPS issues.


Recommended Posts

OK I am officially saying I am truly stumped on this one, and in need of some real advice.

I am having problems with TPS rates, if I join my server TPS report at 20.0 which is good, but in a short space of time I can watch this figure drop and drop until its at around 3.0 TPS.

This is the strange part, if i travel to the nether the TPS in the overworld creeps back up again until its back at 20.0

This is the same for any player of the server, I have tried the following:

- Removed the plugins - definitely not a plugin problem

- Cleared the world anchors

- Turned world anchors off

- Went to the nether and back… and still see the TPS slowly return to normal but drop again when I return to the overworld.

- Renamed the forcedchunks.dat thinking it was a chunk loading thing

-rw-rw---- 1 mc2 mc2 22 Jun 14 01:16 forcedchunks.dat

-rwxrwx--- 1 mc2 mc2 8059 Jun 14 00:04 forcedchunks.dat.old

This is the recent crashreport, i visited 211.50, 12.00, -1256.50 which was in the error. All there was a missile, removed the missile in question.

---- Minecraft Crash Report ----

// On the bright side, I bought you a teddy bear!

Time: 6/13/13 10:58 PM

Description: Ticking entity

java.lang.NullPointerException

at net.minecraftforge.common.ForgeChunkManager.forceChunk(ForgeChunkManager.java:719)

at icbm.common.daodan.EDaoDan.updateLoadChunk(EDaoDan.java:252)

at icbm.common.daodan.EDaoDan.j_(EDaoDan.java:309)

at yc.a(World.java:2291)

at in.a(WorldServer.java:647)

at yc.g(World.java:2253)

at yc.h(World.java:2107)

at in.h(WorldServer.java:516)

at net.minecraft.server.MinecraftServer.r(MinecraftServer.java:680)

at ho.r(DedicatedServer.java:270)

at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:599)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:497)

at fy.run(SourceFile:849)

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

-- Head --

Stacktrace:

at net.minecraftforge.common.ForgeChunkManager.forceChunk(ForgeChunkManager.java:719)

at icbm.common.daodan.EDaoDan.updateLoadChunk(EDaoDan.java:252)

at icbm.common.daodan.EDaoDan.j_(EDaoDan.java:309)

at yc.a(World.java:2291)

at in.a(WorldServer.java:647)

at yc.g(World.java:2253)

-- Entity being ticked --

Details:

Entity Type: ICBMMissile (icbm.common.daodan.EDaoDan)

Entity ID: 1

Name: Nuclear Missile

Exact location: 211.50, 12.00, -1256.50

Block location: World: (211,12,-1257), Chunk: (at 3,0,7 in 13,-79; contains blocks 208,0,-1264 to 223,255,-1249), Region: (0,-3; contains chunks 0,-96 to 31,-65, blocks 0,0,-1536 to 511,255,-1025)

Momentum: 0.00, 0.00, 0.00

Stacktrace:

at yc.h(World.java:2107)

at in.h(WorldServer.java:516)

From doing all this I can not work out what is going on, is there anyone out there that might be able to spread some light on what is going on before I have to restore my entire world which will do nothing but pee of all my players as they will lose their hard work

Ellis

Link to comment
Share on other sites

Thought I would update this thread, I have resolved this issue, it was none of the problems above, it turned out that a player had gone out 20,000 blocks on the Nether world and had been using lots of antimatter missiles and they were still going off, I installed world border and reduced the size of the world significantly and trimmed off the excess, and tadaaa! no more lag so were back open for business now.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...