Jump to content

Tekkit and permissions to use mod items. "modifyworld" "permissions PEX"

Recommended Posts

Hi everyone.

i am trying to get some tekkit items disabled.

been trying for a few days now. and it seems to be able to block normal items. did a test with a mushroom. the player i put the - permission into, could not pick it up.

So i need to know if there is something preventing modifyworld to block items such as Philosophors Stone, and all the grief rings. :-/ .

this is how my config looks like.




- -modifyworld.items.use.27526:41

- -modifyworld.items.have.27526:41

- -modifyworld.items.pickup.27526:41

- commandbook.kit.kits.starter

- commandbook.kit.list

- commandbook.kit.kits.basic

- commandbook.home.teleport

- commandbook.home.set

- commandbook.who

- commandbook.motd

- commandbook.rules

- commandbook.msg

- commandbook.msg

- commandbook.whereami

- commandbook.bans.isbanned

- commandbook.spawn

- multihome.namedhome.*

- multihome.defaulthome.*

- commandbook.call

- choptree.chop

- multihome.listinvites.tome

- multihome.namedhome.uninvite

- multihome.namedhome.invitetimed

- multihome.namedhome.invite

- multihome.namedhome.delete

- multihome.namedhome.set

- multihome.namedhome.go

- multihome.namedhome.list

- multihome.defaulthome.uninvite

- multihome.defaulthome.invitetimed

- multihome.defaulthome.invite

- multihome.defaulthome.set

- multihome.defaulthome.go

- multihome.home

- multihome.namedhome

- multihome.sethome

- multihome.setnamedhome

- multihome.deletehome

- multihome.homeondeath

- multihome.invitehome

- multihome.invitenamedhome

- multihome.invitetimedhome

- multihome.invitenamedtimedhome

- multihome.uninvitehome

- multihome.uninvitenamedhome

- multihome.listinvites.toothers

- showcase.buy.infinite

- showcase.buy.finite

- deathtpplus.deaths

- deathtpplus.streak

- triggercmds

- stargate.dhd.*

- stargate.dhd.use

- stargate.use

- lockette.admin.create.*

- modifyworld.*

default: true

prefix: '&3[student]&f'

This rank is the beginner rank. Everyone who joins the server will have this.

And the stone is only for testing. i guess when i get that to work. Everything else will just be copy paste the item ids into a new row.

So please guys. If anyone knows anything about what can be my problem, Please tell me.

Been fidleling with this the past 3 days. Searching all the forums. And none of the ansvers ever worked on my server. :-/.

Link to comment
Share on other sites

I'm not an expert with PeX, but perhaps having modifyworld.* at the end there is overriding the previous blocks? have you tried putting it at the beginning?

I haven't used the plugin before myself so if that is obviously wrong, don't listen to me.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...