blockhead2002@

Have any tips on making my game lag less when I play this modpack?

Recommended Posts

The problem is most likely MapWriter. My GF was having a similar problem on her laptop. After some tinkering I tried this.

 

Navigate to your appdata folder > Roaming > .technic > modpack > attack-of-the-bteam > Config.

 

Find MapWriter.cfg and open it up in word pad or similar. Then change the options settings to:

 

####################
# options
####################
 
options {
    I:backgroundTextureMode=0
    I:chunksPerTick=2
    I:coordsEnabled=0
    I:coordsMode=0
    I:linearTextureScaling=1
    I:mapPixelSnapEnabled=0
    I:maxChunkSaveDistSq=1024
    I:maxDeathMarkers=3
    I:overlayModeIndex=0
    I:overlayZoomLevel=0
    I:playerTrailEnabled=0
    I:playerTrailMarkerIntervalMillis=5000
    I:playerTrailMaxLength=30
    I:portNumberInWorldNameEnabled=1
    I:regionFileOutputEnabledMP=0
    I:regionFileOutputEnabledSP=0
    S:saveDirOverride=
    S:teleportCommand=tp
    I:teleportEnabled=1
    I:textureSize=512
    I:undergroundMode=0
    I:useSavedBlockColours=0
    I:zoomInLevels=5
    I:zoomOutLevels=5
}

 

 

Note: you cant change the settings this low in game. Doing so will result in a more detailed map generation and thus lag spikes.

 

If this does help you could all ways remove the mod if your not to bothered about the map.

Share this post


Link to post
Share on other sites

The problem is most likely MapWriter. My GF was having a similar problem on her laptop. After some tinkering I tried this.

 

Navigate to your appdata folder > Roaming > .technic > modpack > attack-of-the-bteam > Config.

 

Find MapWriter.cfg and open it up in word pad or similar. Then change the options settings to:

 

 

Note: you cant change the settings this low in game. Doing so will result in a more detailed map generation and thus lag spikes.

 

If this does help you could all ways remove the mod if your not to bothered about the map.

Yo dude thank you so much, I created this account just to thank you LOVE U MAN no homo

Share this post


Link to post
Share on other sites

The other trigger for this kind of behaviour is having RAM allocated in the launcher at 1GB or less - setting it anywhere from 1.5GB to 3GB should eliminate this kind of framerate loss.

 

Set the allocated RAM for a pack by clicking the cog in the top right hand corner of the Technic Launcher.

Share this post


Link to post
Share on other sites

Here are some things you can try to improve Minecraft's performance:

Install optifine

 

Reduce graphics settings; set render distance to tiny, set advanced open GL to off, particles to minimal, smooth lighting to off, graphics to fast, and clouds off.

 

Close any other applications/programs that you are not using.

 

Avoid having a browser window open with any sort of streaming media or flash media running

 

Don't play while doing a disk defrag, registry maintenance, virus/malware scan, etc as these actions oftentimes use up alot of CPU power.

 

If you have a dual-core or quad-core processor, search for and download UnparkCPU (It's the first link, website is codebag) to check if any of your cores are "parked" and use it to "unpark them", you'll need to re-boot your PC after doing this for changes to take effect. *Do note that doing this on a laptop will sacrifice battery life for CPU power, if you plain on being on battery power for an extended period of time, use the unparkcpu program to park the previously unparked cores.

 

Go to Control Pannel (Large/Small Icons listing) >Power Options>Select a Power Plain> Click "High Performance"

*Again, like with processor unparking, this will sacrifice total battery life for more performance. Set it back to Power Saver if you plain to being on battery for long periods of time.

 

Allocate more RAM if possible, (I have mine set to 2GB and it works mostly fine with a few exceptions) but leave at least apx. 1GB of RAM open, windows doesn't like cramped spaces.

 

Play in windowed mode, not maximized.

 

Use the default resource pack. Sphax is cool and all, but 64x and even 32x can be tasking on an older system.

 

DON'T ENTER THE PROMISED LAND until you edit the biomes'o plenty config file: located in %roaming%/attack-of-the-bteam/config/biomesoplenty/ids, press ctrl+f and type in "Pixie" set the value after = to 0. Also it may help to navigate to %roaming%/attack-of-the-bteam/config/biomesoplenty/misc press ctrl+f and type in "puddles" and set the value for "Enable Puddles During Rain" to False

 

Ensure you are using the 64-bit version of Java (provided you have a 64bit Operating System)

 

Some Lag spikes occur because of some mods.

Using Archimedes ships with particles set to anything but Minimal causes lag spikes when getting near/entering water near the ship, Some worlds I had suffered Lag Spikes of Death (0 FPS) when I was in a Mountain Biome and flew in creative mode to ~Y:168 and above, When in the Promised Land, I suffer from Lag Spikes when new chunks are loaded, though this is a general Minecraft lighting engine issue that occurs with any skylands-like mod including the Aether/Aether II and Mystcraft (Stupid cave worlds! Y U SO AWESOME YET LAG SO BAD?!)

 

Some words of warning:

1) Avoid using carpenter's blocks with Archimedes ships, also avoid using glass panes, and non-vinilla "non-cubic" blocks. (I.E. microblocks) Tropicraft Chests, and chisel blocks work fine though.

 

2) Back up your worlds every time you finish playing. One time, I had my client crash to desktop, and when I re-launched my game, the world I was last on WAS GONE! The Save Folder was there, but the file was corrupted to the point where Minecraft couldn't read it anymore! :c (This happened in ATOTBT 1.0.8, it has yet to happen to me in 1.0.9c)

 

I hope this helps resolve your issue.

Share this post


Link to post
Share on other sites
On 3/14/2014 at 6:00 AM, Loader said:

The other trigger for this kind of behaviour is having RAM allocated in the launcher at 1GB or less - setting it anywhere from 1.5GB to 3GB should eliminate this kind of framerate loss.

 

Set the allocated RAM for a pack by clicking the cog in the top right hand corner of the Technic Launcher.

The highest option is 1GB though, at least for me. I've heard setting it to 3GB will help, but I've only ever seen that with classic Minecraft.

Share this post


Link to post
Share on other sites
On 2/17/2014 at 7:02 AM, pattymq said:

The problem is most likely MapWriter. My GF was having a similar problem on her laptop. After some tinkering I tried this.

 

Navigate to your appdata folder > Roaming > .technic > modpack > attack-of-the-bteam > Config.

 

Find MapWriter.cfg and open it up in word pad or similar. Then change the options settings to:

 

 

Note: you cant change the settings this low in game. Doing so will result in a more detailed map generation and thus lag spikes.

 

If this does help you could all ways remove the mod if your not to bothered about the map.

Does this only work for Attack of the B-Team though?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.