Jump to content

Tinker's construct / Carpenter's blocks and Optifine aren't playing nice


Stillborn
 Share

Recommended Posts

I'm addressing these issues so others can use this as a guideline or help come up with a solution (if there isn't already one)

 

I only have these issues when Optifine (and core shaders) is installed, together with Attack Of The B-Team. Without Optifine, AOTBT runs fine.

 

The Optifine mod appears to have issues with Tinker's Construct:

1. Many times certain body parts like limbs or heads go missing/invisible.

This occurs on all mobs, as well as player characters.

The fix for me was to set Chunk loading from multicore to default

 

The Optifine mod also seems to don't go along with Carpenter's Blocks:

2. When using the chisel to add detail to Carpenter's Blocks, the texture disappears and turns into a "missing texture" shader.
The block is turning into this texture: '>

I haven't found a solution for this, except for removing Optifine, but then I would also not have the benefit of the Shaders that make it so pretty.


Anybody, please help!

 

 

Cheers!

Link to comment
Share on other sites

I'm afraid most of these are known bugs with optifine not playing nice, please contact them and let them know about this as well if you want a fix (you might be lucky here if someone is using it same as you, but it's not officially supported so most people won't have it or be able to help with it here).

Link to comment
Share on other sites

  • 2 months later...

I'm addressing these issues so others can use this as a guideline or help come up with a solution (if there isn't already one)

 

I only have these issues when Optifine (and core shaders) is installed, together with Attack Of The B-Team. Without Optifine, AOTBT runs fine.

 

The Optifine mod appears to have issues with Tinker's Construct:

1. Many times certain body parts like limbs or heads go missing/invisible.

This occurs on all mobs, as well as player characters.

The fix for me was to set Chunk loading from multicore to default

 

The Optifine mod also seems to don't go along with Carpenter's Blocks:

2. When using the chisel to add detail to Carpenter's Blocks, the texture disappears and turns into a "missing texture" shader.

The block is turning into this texture: '>

I haven't found a solution for this, except for removing Optifine, but then I would also not have the benefit of the Shaders that make it so pretty.

Anybody, please help!

 

 

Cheers!

 

Thank you TONS.  #1 is exactly the issue I've been having (with a FtB modpack) and I couldn't find an answer, but this fixed my problem as well. 

 

<3  Now I can feel ok recording with shaders!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...